Ask Your Question
0

Problem with turtlebot computers setup

asked 2013-03-09 12:00:25 -0500

SaiHV gravatar image

updated 2014-04-20 14:09:25 -0500

ngrennan gravatar image

Hello,

I am encountering problems when trying to set up the computers for running a turtlebot. Here is the setup info:

Turtlebot netbook - Electric - 192.168.1.3 (tbot) Workstation - Groovy - 192.168.1.2 (work)

ROS_MASTER_URI : "http://192 . 168 . 1 . 3:11311" ROS_IP : "192 . 168 . 1 . 3"

(set on both computers)

I can ssh into tbot from work and viceversa. I can ping both machines from each other. netcat listening works fine. But using "rostopic list" on the workstation gives out "Unable to communicate with master!" error.

Also, according to the tutorials, if I use "rostopic echo /diagnostics" on the netbook, it should report a warning saying that "diagnostics has not been published", but in this case, it just prints some diagnostic info saying that dev/ttyUSB0 is not connected.

roscore is indeed running on 192.168.1.3:11311, but the workstation is unable to find it. Looking forward to your suggestions. Thanks in advance.

edit retag flag offensive close merge delete

Comments

The master is usually port 11311, are you sure yours is 11611?

Jon Stephan gravatar imageJon Stephan ( 2013-03-09 13:52:48 -0500 )edit

Sorry, that was a typo. I typed this from Windows. Corrected.

SaiHV gravatar imageSaiHV ( 2013-03-09 13:54:51 -0500 )edit

Does Windows not support "3" any more? :-D

bit-pirate gravatar imagebit-pirate ( 2013-03-14 15:11:18 -0500 )edit

No, I meant I forgot what the port was as I was in Windows and couldn't run roscore to check.

SaiHV gravatar imageSaiHV ( 2013-03-14 15:19:20 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-14 15:15:45 -0500

SaiHV gravatar image

Hello,

As I mentioned, I did a clean install of linux on the turtlebot and installed ROS Groovy and the turtlebot apps, and the setup started working. Thanks for your comments.

edit flag offensive delete link more

Comments

congratulations

Chik gravatar imageChik ( 2013-03-14 15:32:08 -0500 )edit
0

answered 2013-03-10 20:02:48 -0500

Chik gravatar image

My suggestion would be simply reboot your workstation and turtlebot laptop and then check

echo $ROS_MASTER_URI

echo $ROS_HOSTNAME

to see if they are correct or not. In my case I need to set the IP (echo export...) 3 times and reboot 3 times before it works. Sometimes the computer suddenly reset them to localhost without reason...

Another issue may be Electric in laptop but Groovy in Workstation. In my case I installed Electric in both.

edit flag offensive delete link more

Comments

Rebooted multiple times, no luck. Switched to 10.04 and installed electric on the workstation, still nothing. Now as a last resort, I am just doing a clean install on the netbook and installing groovy on both to see if that will resolve anything. Thanks for the tips.

SaiHV gravatar imageSaiHV ( 2013-03-12 17:00:21 -0500 )edit

Sorry to hear that. Perhaps you should contact the distributor (Clearpath?)

Chik gravatar imageChik ( 2013-03-13 14:51:20 -0500 )edit
0

answered 2013-03-09 14:04:55 -0500

I have my system set up with names instead of IP addresses. My /etc/hosts files have the IP addresses of both machines in both files. Then I just set ROS_MASTER_URI=http://hostname:11311, and not ROS_IP.

I think if you're using ROS_IP, each machine needs it set to it's own IP. (Did you set both machines' ROS_IP to the master's IP?)

edit flag offensive delete link more

Comments

Ah. I set both of them to the turtlebot netbook's IP. So if I use ROS_HOSTNAMEs instad; the ROS_HOSTNAME of the workstation would just be the workstation's name?

SaiHV gravatar imageSaiHV ( 2013-03-09 17:31:27 -0500 )edit

I think if you have the /etc/hosts set up on both machines, then you don't need to set ROS_HOSTNAME.

Jon Stephan gravatar imageJon Stephan ( 2013-03-10 13:54:49 -0500 )edit

No amount of tweaking the ROS_HOSTNAME / ROS_IP in the machines gave any results, unfortunately. Thanks for the suggestions though.

SaiHV gravatar imageSaiHV ( 2013-03-12 16:56:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-09 12:00:25 -0500

Seen: 195 times

Last updated: Mar 14 '13