Ask Your Question
0

qemu failure while making chroot for raspbian

asked 2013-03-03 07:04:11 -0500

tulumbas gravatar image

updated 2014-01-28 17:15:29 -0500

ngrennan gravatar image

Hi folks,

I tried to create a chroot environmnent in accordance with ROS dox "groovy / installation / Raspbian" in ORacle VBox. Host OS is debian-6.0.7-amd64 squeeze, 2 virtual CPU. Image file I dd'ed from SD card which has 2013-02-09 Raspbian wheezy (it's running OK on Raspberry). Image mounted OK, I can see it under mounting point /mnt/sdb1/raspb, but when I run sudo chroot /mnt/sdb1/raspb

qemu fails with

qemu: fatal: cp15 insn ee070fba

and then register dump...

any ideas how this can be fixed?

Thanks

edit retag flag offensive close merge delete

Comments

No ideas I guess

tulumbas gravatar image tulumbas  ( 2013-03-09 22:29:22 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-03-10 16:40:44 -0500

kalectro gravatar image

updated 2013-03-10 16:41:46 -0500

Qemu chroot will not work on the latest raspbian release. It does work on the release from december. You can still download it from here. I will also add this information to the wiki since I had to find it out the hard way as well.

edit flag offensive delete link more

Comments

thanks for giving a clue - I've spent quite lot of time. Any ideas when fresh kernel will be supported? I appreciate you could be wrong person to ask, just wondering...

tulumbas gravatar image tulumbas  ( 2013-03-14 03:42:14 -0500 )edit

Ah, found a branch of RasPi forum...

tulumbas gravatar image tulumbas  ( 2013-03-14 05:05:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-03 07:04:11 -0500

Seen: 225 times

Last updated: Mar 10 '13