Ask Your Question
0

rosmake does not respect ROS_PARALLEL_JOBS or --pjobs

asked 2013-02-26 19:21:09 -0500

yoos gravatar image

updated 2014-01-28 17:15:26 -0500

ngrennan gravatar image

rosmake in ROS fuerte does not seem to respect the ROS_PARALLEL_JOBS=-jN environment variable nor the --pjobs=N command line option for compiling with N+1 processes.

Instead, the number of rosmake instances spawned is always equal to the number of cores detected (regardless of whether or not that is more or fewer than the number specified via ROS_PARALLEL_JOBS or --pjobs).

The ROS wiki page on environment variables says setting ROS_PARALLEL_JOBS should work, but I have multiple installations of ROS that display this behavior.

Has anyone else had this problem?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-27 00:41:52 -0500

KruseT gravatar image

That bug is known: https://code.ros.org/trac/ros/ticket/4036 https://github.com/ros/ros/issues/4 and a fix will be soon be released for fuerte and later.

In the meantime a workaround is using this (for experts):

export MAKEFLAGS="-j8"
edit flag offensive delete link more
0

answered 2013-02-26 20:01:08 -0500

yoos gravatar image

Never mind, --threads does what I need it to do.

edit flag offensive delete link more
0

answered 2013-02-26 22:45:56 -0500

updated 2013-02-26 22:47:00 -0500

export ROS_PARALLEL_JOBS='-j6 -l6'

works for me on ubu 11.10 and 12.04

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-26 19:21:09 -0500

Seen: 251 times

Last updated: Feb 27 '13