Ask Your Question
1

Problem Installing Groovy on Ubuntu 12.04 LTS

asked 2013-02-25 10:19:29 -0500

nicobari gravatar image

updated 2013-02-25 10:29:19 -0500

Hi, I am trying to begin working with ROS and I am completely new to ROS and I already have Ubuntu 12.04 LTS installed on my desktop. I configured the repositories, set up the sources.list, set up the keys ran sudo apt-get update and then called sudo apt-get install ros-groovy-desktop-full but I am getting the following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ros-groovy-desktop-full: Depends: ros-groovy-ros-tutorials (= 0.3.9-0precise-20130125-2301-+0000) but it is not going to be installed
                           Depends: ros-groovy-nodelet-core (= 1.7.14-0precise-20130129-0936-+0000) but it is not going to be installed
                           Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1360129594~precise) but it is not going to be installed
                           Depends: ros-groovy-geometry-tutorials (= 0.1.3-s1359158777~precise) but it is not going to be installed
                           Depends: ros-groovy-orocos-kinematics-dynamics (= 0.2.3-s1359529309~precise) but it is not going to be installed
                           Depends: ros-groovy-filters (= 1.6.0-s1359446119~precise) but it is not going to be installed
                           Depends: ros-groovy-slam-gmapping (= 1.2.7-s1360121475~precise) but it is not going to be installed
                           Depends: ros-groovy-ros (= 1.9.42-0precise-20130125-2011-+0000) but it is not going to be installed
                           Depends: ros-groovy-qt-gui-core (= 0.2.12-0precise-20130129-0828-+0000) but it is not going to be installed
                           Depends: ros-groovy-python-qt-binding (= 0.2.8-0precise-20130125-2005-+0000) but it is not going to be installed
                           Depends: ros-groovy-vision-opencv (= 1.10.4-0precise-20130202-1411-+0000) but it is not going to be installed
                           Depends: ros-groovy-perception-pcl (= 1.0.28-0precise-20130205-2103-+0000) but it is not going to be installed
                           Depends: ros-groovy-rqt-common-plugins (= 0.2.10-0precise-20130202-1459-+0000) but it is not going to be installed
                           Depends: ros-groovy-actionlib (= 1.9.11-0precise-20130125-2100-+0000) but it is not going to be installed
                           Depends: ros-groovy-pluginlib (= 1.9.18-0precise-20130129-0745-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-pipeline (= 1.10.4-0precise-20130205-2106-+0000) but it is not going to be installed
                           Depends: ros-groovy-bfl (= 0.1.0-s1359146203~precise) but it is not going to be installed
                           Depends: ros-groovy-stage (= 1.6.7-s1359158824~precise) but it is not going to be installed
                           Depends: ros-groovy-rqt-robot-plugins (= 0.2.8-0precise-20130205-1931-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-common (= 1.10.0-0precise-20130129-0904-+0000) but it is not going to be installed
                           Depends: ros-groovy-bond-core (= 1.7.10-0precise-20130125-2050-+0000) but it is not going to be installed
                           Depends: ros-groovy-common-tutorials (= 0.2.3-s1359455939~precise) but it is not going to be installed
                           Depends: ros-groovy-ros-comm (= 1.9.41-0precise-20130125-2334-+0000) but it is not going to be installed
                           Depends: ros-groovy-physics-ode (= 1.8.0-s1359145319~precise) but it is not going to be installed
                           Depends: ros-groovy-driver-common (= 1.6.5-0precise-20130126-0009-+0000) but it is not going to be installed
                           Depends: ros-groovy-executive-smach (= 1.2.0-s1359158282~precise) but it is not going to be installed
                           Depends: ros-groovy-common-msgs (= 1.9.14-0precise-20130125-0519-+0000) but it is not going ...
(more)
edit retag flag offensive close merge delete

Comments

Do you have enabled the community packages? The easiest way is to run sudo synaptic, go to Settings|Repositories and activate all Ubuntu sources except Source Code, i.e. main, restricted, universe and multiverse.

roehling gravatar image roehling  ( 2013-02-25 10:42:22 -0500 )edit

Are all your system packages up-to-date? Run sudo apt-get dist-upgrade and make sure that no packages have to be upgraded. Do you have any other third party repositories or PPAs which might clash with the ROS ones? Lastly, try to install the bare-bones system ros-groovy-ros and see if that works

roehling gravatar image roehling  ( 2013-02-28 00:52:54 -0500 )edit

has someone found a solution to this issue? I am not able to find a solution :-/ This thread doesn't seem to fix it either http://bit.ly/12W9dLy

ferre gravatar image ferre  ( 2013-04-29 18:18:45 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2014-03-09 10:54:49 -0500

Miško gravatar image

Check if you have been selected right distro on source.list. This happened to me, that I put the ubuntu 12.10 instead of 12.04, and this occurred to me :)

edit flag offensive delete link more
0

answered 2013-07-30 03:30:40 -0500

cyberguy42 gravatar image

I had this exact issue. The thing that made it work was using aptitude (get it by 'sudo apt-get install aptitude'). Then you can use 'sudo aptitude install ros-groovy-desktop-full'.

The first solution involved not installing those same packages listed by apt-get as having unmet dependencies. I pressed 'n', to search for another solution, and it offered to downgrade some packages and remove others (all ones I did not need), which resolved the dependencies and allowed me to install.

edit flag offensive delete link more
0

answered 2013-02-27 22:44:26 -0500

This is NOT an answer.

I'm just also new and restricted from writing comments. I'm experiencing the same problem as @nicobari. The suggestion in the comment by @roehling did not work for me.

edit flag offensive delete link more

Comments

1

If it is not an answer, then post it as a comment.

Hansg91 gravatar image Hansg91  ( 2013-02-27 22:51:44 -0500 )edit
1

I quote myself: "I'm just also new and restricted from writing comments." The discussion of this restriction is completely off-topic, I know. I do apologize for the inconvenience, but I really wanted my information communicated.

RafBerkvens gravatar image RafBerkvens  ( 2013-02-27 23:14:15 -0500 )edit

@roehling: all packages are up-to-date, including the dist-upgrade. I have no PPAs which clash, unless these inlcude Google Chrome, Mendeley, Dropbox, or JDownloader, all of which are very distinct from ROS. Same type of error when installing ros-groovy-ros.

RafBerkvens gravatar image RafBerkvens  ( 2013-02-28 00:57:48 -0500 )edit

After trying to add packages recursively, I found that ros-groovy-rospack depends on libboost-all-dev. Here, the story starts again. However, I do have boost installed. There's two version in the repo's: the default and 1.48. I'm on the 1.48.

RafBerkvens gravatar image RafBerkvens  ( 2013-02-28 01:00:23 -0500 )edit

What happens if you try to install libboost-all-dev? Dev-Packages from different Boost versions cannot coexist, so this may very well be your problem.

roehling gravatar image roehling  ( 2013-02-28 01:10:08 -0500 )edit

The same style of error, just with boost packages. Then if I try to install those separately, for example Boost.Test, I get "Depends: libboost-test1.46-dev but ...", since I already have libboost-test1.48-dev installed. I think that ROS requires libboost-all-dev and that I have libboost1.48-all-dev.

RafBerkvens gravatar image RafBerkvens  ( 2013-02-28 01:13:59 -0500 )edit

Try sudo apt-get remove libboost.*dev to uninstall the Boost 1.48 Dev-Packages. Then it should work. You won't be able to develop with Boost 1.48 though, unless you are willing to upgrade to a newer Ubuntu version.

roehling gravatar image roehling  ( 2013-02-28 01:27:26 -0500 )edit

In fact, other projects of mine depend on Boost 1.48 already. This won't quickly fix the problem for me, but I hope it might for others. I'll have to see whether I can migrate back to 1.46.

RafBerkvens gravatar image RafBerkvens  ( 2013-02-28 01:35:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-25 10:19:29 -0500

Seen: 1,098 times

Last updated: Mar 09 '14