Why no Kinect depth and RGB image? Kinect driver not working [closed]

asked 2013-02-25 00:35:19 -0600

promach gravatar image

updated 2016-10-24 08:34:34 -0600

ngrennan gravatar image

Hi, I just installed ros-electric-openni-kinect and NITE-Bin-Dev-Linux-x86-v1.5.2.21 but the Kinect seems only work on NITE samples located in /Samples/Bin/x86-Release under NITE directory. I have Ubuntu 10.04 Lucid and ROS Electric and plan to run www.ros.org/wiki/mit-ros-pkg/KinectDemos

When I tried rosrun rviz rviz , I have this:

dell@ubuntu:~/ros_workspace$ rosrun rviz rviz The program 'rviz' received an X Window System error. This probably reflects a bug in the program. The error was 'BadDrawable (invalid Pixmap or Window parameter)'. (Details: serial 22 error_code 9 request_code 136 minor_code 3) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)

When I tried the instruction on www.robotas.at/ros-and-kinect-ubuntu-installation/ I have the following console output

dell@ubuntu:~/ros_workspace$ roslaunch openni_launch openni.launch ... logging to /home/dell/.ros/log/2b48cda0-7ef7-11e2-bc6a-0018dea5a2c6/roslaunch-ubuntu-23309.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http://)ubuntu:41212/

PARAMETERS * /rosdistro * /camera/driver/rgb_frame_id * /camera/disparity_depth_registered/min_range * /camera/driver/rgb_camera_info_url * /camera/depth_registered/rectify_depth/interpolation * /camera/driver/depth_frame_id * /camera/depth/rectify_depth/interpolation * /camera/disparity_depth/max_range * /rosversion * /camera/driver/device_id * /camera/driver/depth_camera_info_url * /camera/disparity_depth/min_range * /camera/disparity_depth_registered/max_range

NODES /camera/depth/ rectify_depth (nodelet/nodelet) metric_rect (nodelet/nodelet) metric (nodelet/nodelet) points (nodelet/nodelet) /camera/rgb/ debayer (nodelet/nodelet) rectify_mono (nodelet/nodelet) rectify_color (nodelet/nodelet) / camera_nodelet_manager (nodelet/nodelet) camera_base_link (tf/static_transform_publisher) camera_base_link1 (tf/static_transform_publisher) camera_base_link2 (tf/static_transform_publisher) camera_base_link3 (tf/static_transform_publisher) /camera/ driver (nodelet/nodelet) register_depth_rgb (nodelet/nodelet) points_xyzrgb_depth_rgb (nodelet/nodelet) disparity_depth (nodelet/nodelet) disparity_depth_registered (nodelet/nodelet) /camera/ir/ rectify_ir (nodelet/nodelet) /camera/depth_registered/ rectify_depth (nodelet/nodelet) metric_rect (nodelet/nodelet) metric (nodelet/nodelet)

ROS_MASTER_URI=(http://)localhost:11311

core service [/rosout] found process[camera_nodelet_manager-1]: started with pid [23327] process[camera/driver-2]: started with pid [23328] process[camera/rgb/debayer-3]: started with pid [23329] process[camera/rgb/rectify_mono-4]: started with pid [23330] process[camera/rgb/rectify_color-5]: started with pid [23331] process[camera/ir/rectify_ir-6]: started with pid [23337] process[camera/depth/rectify_depth-7]: started with pid [23350] process[camera/depth/metric_rect-8]: started with pid [23373] process[camera/depth/metric-9]: started with pid [23380] process[camera/depth/points-10]: started with pid [23385] process[camera/register_depth_rgb-11]: started with pid [23395] process[camera/depth_registered/rectify_depth-12]: started with pid [23400] process[camera/depth_registered/metric_rect-13]: started with pid [23408] process[camera/depth_registered/metric-14]: started with pid [23419] process[camera/points_xyzrgb_depth_rgb-15]: started with pid [23421] process[camera/disparity_depth-16]: started with pid [23434] process[camera/disparity_depth_registered-17]: started with pid [23440] process[camera_base_link-18]: started with pid [23444] process[camera_base_link1-19]: started with pid [23457] process[camera_base_link2-20]: started with pid [23478] process[camera_base_link3-21]: started with pid [23482}[INFO] [1361795173.213414092]: Number devices connected: 1 {INFO] [1361795173.214269438]: 1. device on bus 001:32 is ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-30 17:59:42.589185

Comments

when I run rostopic hz /camera/depth_registered/points, I only got "subscribed to [/camera/depth_registered/points]" and a hang terminal

promach gravatar imagepromach ( 2013-02-25 01:00:00 -0600 )edit

when I tried rosrun dynamic_reconfigure reconfigure_gui , I cannot locate the entry "/camera/driver" from the drop-down menu as published on http://www.ros.org/wiki/openni_launch

promach gravatar imagepromach ( 2013-02-25 03:46:12 -0600 )edit