Ask Your Question
0

Installing ROS for an NXT

asked 2013-02-09 12:22:14 -0500

FIRSTlover gravatar image

Hi, I am interested in using ROS to program an NXT. I am very new to ROS and Linux, but not to robotics and I am interested in learning ROS. When I add the following line to terminal:

sudo apt-get install ros-electric-nxtall

I get the text below in terminal. Is the electric version the proper version that I need to use? How can I fix this problem? Thank you for your help!

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-diamondback-nxtall : Depends: ros-diamondback-nxt-apps (= 0.1.1-s1315535128~natty) but it is not going to be installed Depends: ros-diamondback-slam-gmapping (= 1.2.3-s1315532575~natty) but it is not going to be installed Depends: ros-diamondback-joystick-drivers (= 1.4.2-s1315007432~natty) but it is not going to be installed Depends: ros-diamondback-ros (= 1.4.10-s1314988837~natty) but it is not going to be installed Depends: ros-diamondback-visualization (= 1.4.1-s1315011843~natty) but it is not going to be installed Depends: ros-diamondback-perception-pcl (= 0.10.0-s1315007603~natty) but it is not going to be installed Depends: ros-diamondback-rx (= 1.4.2-s1315010621~natty) but it is not going to be installed Depends: ros-diamondback-diagnostics-monitors (= 1.4.0-s1315018722~natty) but it is not going to be installed Depends: ros-diamondback-image-common (= 1.4.1-s1315006405~natty) but it is not going to be installed Depends: ros-diamondback-nxt-robots (= 0.1.2-s1315534008~natty) but it is not going to be installed Depends: ros-diamondback-ros-comm (= 1.4.8-s1314988916~natty) but it is not going to be installed Depends: ros-diamondback-visualization-common (= 1.4.2-s1315010803~natty) but it is not going to be installed Depends: ros-diamondback-driver-common (= 1.2.3-s1315006323~natty) but it is not going to be installed Depends: ros-diamondback-executive-smach (= 1.0.3-s1320177847~natty) but it is not going to be installed Depends: ros-diamondback-common-msgs (= 1.4.0-s1315005773~natty) but it is not going to be installed Depends: ros-diamondback-nxt (= 0.1.1-s1315020497~natty) but it is not going to be installed Depends: ros-diamondback-robot-model (= 1.4.0-s1315008455~natty) but it is not going to be installed Depends: ros-diamondback-geometry (= 1.4.2-s1315006035~natty) but it is not going to be installed Depends: ros-diamondback-executive-smach-visualization (= 1.0.1-s1321804721~natty) but it is not going to be installed Depends: ros-diamondback-laser-pipeline (= 1.2.0-s1315009845~natty) but it is not going to be installed Depends: ros-diamondback-common (= 1.4.3-s1315005864~natty) but it is not going to be installed Depends: ros-diamondback-diagnostics (= 1.4.0-s1315006219~natty) but it is not going to be installed Depends: ros-diamondback-navigation (= 1.4.2-s1315423226~natty) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-10 07:20:30 -0500

davinci gravatar image

It is better to upgrade your ubuntu installation to the latest LTS version and install ROS fuerte or groovy.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-09 12:22:14 -0500

Seen: 66 times

Last updated: Feb 09 '13