Ask Your Question
11

How do I run unit tests for a catkin package?

asked 2013-02-02 06:25:23 -0500

joq gravatar image

updated 2013-02-02 06:34:41 -0500

The camera_info_manager package was converted to catkin, but I suspect an error: rostest is listed as a <build_depend> and a <run_depend>, rather than a <test_depend>.

I checked out an image_common catkin workspace using wstool. I can build those packages with catkin_make, but have not been able to figure out how to run the camera_info_manager unit tests.

I tried make test in every directory I could think of:

$ make test
make: *** No rule to make target `test'.  Stop.

Google has not revealed any answers. So, how is this done, now?

EDIT: I noticed that <test_depend>gtest</test_depend> was missing and added it. Still not running.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
12

answered 2013-02-02 07:55:29 -0500

WilliamWoodall gravatar image

updated 2014-09-26 12:50:08 -0500

William gravatar image

I believe the make targets are:

  • make tests to build them
  • make run_test* for each test (you can tab complete the targets)
  • make run_tests runs all tests

See:

edit flag offensive delete link more

Comments

Thanks, William. That's what I needed.

joq gravatar imagejoq ( 2013-02-02 10:11:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-02 06:25:23 -0500

Seen: 6,036 times

Last updated: Sep 26 '14