Ask Your Question
3

rospack became agonizingly slow

asked 2013-01-31 23:33:00 -0500

updated 2013-01-31 23:40:01 -0500

Since I upgraded to Groovy, the rospack command has become really slow. This is true even if have no own package tree, just the distribution itself. The rospack profile call runs fast and shows nothing abnormal, but any query takes over a second. Any ideas what is wrong?

$ env | grep ROS_
ROS_ROOT=/opt/ros/groovy/share/ros
ROS_PACKAGE_PATH=/opt/ros/groovy/share:/opt/ros/groovy/stacks
ROS_MASTER_URI=http://localhost:11311
ROS_DISTRO=groovy
ROS_ETC_DIR=/opt/ros/groovy/etc/ros

$ rospack profile
Full tree crawl took 0.019685 seconds.
Directories marked with (*) contain no manifest.  You may
want to delete these directories.
To get just of list of directories without manifests,
re-run the profile with --zombie-only
-------------------------------------------------------------
0.016709   /opt/ros/groovy/share
0.003634 * /opt/ros/groovy/share/common-lisp
0.003559 * /opt/ros/groovy/share/common-lisp/ros
0.002273 * /opt/ros/groovy/share/doc
0.002248   /opt/ros/groovy/stacks
0.002195 * /opt/ros/groovy/share/doc/pcl-1.6
0.002161 * /opt/ros/groovy/share/doc/pcl-1.6/tutorials
0.002027 * /opt/ros/groovy/share/doc/pcl-1.6/tutorials/sources
0.000377 * /opt/ros/groovy/share/ros
0.000346   /opt/ros/groovy/stacks/navigation
0.000314 * /opt/ros/groovy/share/common-lisp/ros/std_msgs
0.000297 * /opt/ros/groovy/share/common-lisp/ros/sensor_msgs
0.000276 * /opt/ros/groovy/share/common-lisp/ros/dynamic_reconfigure
0.000263 * /opt/ros/groovy/share/ros/core
0.000248 * /opt/ros/groovy/share/OpenCV
0.000244 * /opt/ros/groovy/share/common-lisp/ros/geometry_msgs
0.000232 * /opt/ros/groovy/share/common-lisp/ros/actionlib
0.000218 * /opt/ros/groovy/share/doc/pcl-1.6/tutorials/sources/iros2011
0.000176   /opt/ros/groovy/stacks/geometry_experimental
0.000164 * /opt/ros/groovy/share/common-lisp/ros/rospy_tutorials

$ time rospack depends roscpp
cpp_common
rostime
roscpp_traits
roscpp_serialization
genmsg
genpy
message_runtime
rosconsole
std_msgs
rosgraph_msgs
xmlrpcpp

real    0m1.744s
user    0m1.632s
sys 0m0.092s
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-19 20:08:30 -0500

As it turns out, rosdep is at least partially responsible. If you are affected, make sure you have upgraded to at least rosdep 0.10.14 and re-run rosdep update for a noticeable speedup.

edit flag offensive delete link more
5

answered 2013-02-01 01:20:52 -0500

It appears this slow-down is a a known issue, to quote Brian:

Could be because the of the slow-down in rospack with Groovy because of the introduction of a Python interpreter inside it

from here (in an otherwise unrelated xacro issue).

I also noticed this and speed improvements certainly would be welcome.

edit flag offensive delete link more

Comments

1

I did some checking, and the problem is not the Python interpreter per se, but the invocation of init_rospack_interface which is part of the rosdep2 package. Incidentally, the rosdep command line tool is really slow as well. Seems to me that rospack just inherited that problem.

roehling gravatar image roehling  ( 2013-02-03 22:02:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-31 23:33:00 -0500

Seen: 375 times

Last updated: Feb 19 '13