Ask Your Question
2

After update ubuntu 12.04 and groovy, ros doesn't work more?

asked 2013-01-31 05:32:38 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I installed groovy distributed by nootrix. I updated the system with updates of ubuntu and groovy. But after update, it doesn't work more and there is no roscore command now.

When I used command source /opt/ros/groovy/setup.bash to set the environment, there is error as following:

File "<string>", line 1
    import os; print(os.pathsep.join([x for x in "/opt/ros/groovy/bin:# reset environment variables by unrolling modifications based on all workspaces in CMAKE_PREFIX_PATH
                                                                                                                                                                         ^
SyntaxError: EOL while scanning string literal
bash: cat: No such file or directory
bash: python: No such file or directory
/usr/bin/env: python: No such file or directory
/usr/bin/env: python: No such file or directory
/usr/bin/env: python: No such file or directory
/usr/bin/env: python: No such file or directory
/usr/bin/env: python: No such file or directory
bash: which: No such file or directory
bash: which: No such file or directory

Can anyone help me, thank you!

edit retag flag offensive close merge delete

Comments

What is nootrix? Do you have any problem installing ROS using the normal instructions? http://www.ros.org/wiki/groovy/Installation/Ubuntu

joq gravatar image joq  ( 2013-01-31 10:26:25 -0500 )edit

Does the file /opt/ros/groovy/setup.bash exist?

aswin gravatar image aswin  ( 2013-01-31 18:42:19 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-02-03 07:21:21 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am experiencing the same issue. I posted a comment on the Nootrix page here, and they gave a solution, but it didn't work for me. I posted my results in the comments on that page, but they're currently awaiting moderation. In essence, the problem seems to be related to the ~/catkin_ws/devel/setup.bash script; after running it, several environment variables are set like this (here's my PATH variable):

viki@c3po:~$ echo $PATH
# reset environment variables by unrolling modifications based on all workspaces in CMAKE_PREFIX_PATH export CMAKE_PREFIX_PATH=”" export PATH=”/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games” export PKG_CONFIG_PATH=”" export PYTHONPATH=”" # prepend folders of workspaces to environment variables export CMAKE_PREFIX_PATH=”/opt/ros/groovy” export CPATH=”/opt/ros/groovy/include:$CPATH” export LD_LIBRARY_PATH=”/opt/ros/groovy/lib:$LD_LIBRARY_PATH” export PATH=”/opt/ros/groovy/bin:$PATH” export PKG_CONFIG_PATH=”/opt/ros/groovy/lib/pkgconfig” export PYTHONPATH=”/opt/ros/groovy/lib/python2.7/dist-packages”/opt/ros/groovy/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

Clearly, there's stuff in there that shouldn't be there. But I'm also running ROS on a non-VM install of Ubuntu with ROS Groovy, and catkin works fine after system updates there. So there does seem to be be something about the version in the Nootrix VM.

edit flag offensive delete link more

Comments

Can you tar all files in ~/catkin_ws/, and create a ticket on catkin in github attaching the tar, so we can inspect what goes wrong, please? subfolders should not be required. Also if you can post the version of catkin from catkin_ws/src/catkin/package.xml that might help.

KruseT gravatar image KruseT  ( 2013-02-03 11:09:19 -0500 )edit

Sure, I'll do that tomorrow. I should note that the problem described in the comments of Nootrix page (linked above) with the PATH variable being emptied do occur on my non-VM install of ROS. It's only in the VM version that I'm getting the above problem with garbage in PATH.

Jeffrey Kane Johnson gravatar image Jeffrey Kane Johnson  ( 2013-02-03 12:29:59 -0500 )edit
1

Turns out there was a very simple fix for the environment variables issue: I re-initialized the catkin workspace and then I did a catkin_make. Everything now works as expected. Thanks!

Jeffrey Kane Johnson gravatar image Jeffrey Kane Johnson  ( 2013-02-04 03:25:20 -0500 )edit
0

answered 2013-02-01 13:05:18 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Finally, I solved the problem. Thanks everyone who would help me. It's the problem of ROS configure file, and I think it's the duty of ROS. Just comment the first line of file /opt/ros/groovy/etc/catkin/profile.d/10.ros.sh as following:

export PATH=....

And I want to say holy shit now. Pourquoi y a-t-il problème comme ça?

edit flag offensive delete link more

Comments

This solution does not help us at all. We need to know why the PATH variable was set wrongly before this line. And this seems to be specific to the Nootrix virtualbox, as nobody else has this problem, apparently. Commenting this line will just cause other problems later.

KruseT gravatar image KruseT  ( 2013-02-02 03:27:52 -0500 )edit

"And this seems to be specific to the Nootrix virtualbox, as nobody else has this problem, apparently. " -- I have the same problem with regular Ubuntu 12.04 after upgrade.

r0nald gravatar image r0nald  ( 2013-03-05 20:03:12 -0500 )edit

If you can reproduce on Ubuntu, raise an issue on https://github.com/ros/ros

KruseT gravatar image KruseT  ( 2013-03-06 00:01:24 -0500 )edit
0

answered 2013-02-01 01:25:44 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The first error is probably the source of all following errors, so focus on debugging that one.

import os; print(os.pathsep.join([x for x in "/opt/ros/groovy/bin:# reset environment variables by unrolling modifications based on all workspaces in CMAKE_PREFIX_PATH
SyntaxError: EOL while scanning string literal

The python code there is invalid. I assume this is the result of ./etc/catkin/profile.d/10.ros.sh

export PATH=`python -c "import os; print(os.pathsep.join([x for x in \"$PATH\".split(os.pathsep) if not any([d for d in ['cturtle', 'diamondback', 'electric', 'fuerte'] if d in x])]))"`

As you can see, in this expression $PATH is used. In your case, PATH seems to have been set to

"/opt/ros/groovy/bin:# reset environment variables..."

which is not a valid value for PATH. This string seems to be the result of catkins _setup_util.py. So you'd have to backtrack the configuration files to find out where PATH is being set to the wrong value by using _setup_util.py in the wrong way. This should not be too hard to do. Find that location and edit the question telling us which file does so and paste the line.

I assume you use the virtualbox distro from http://nootrix.com/2012/09/virtualizing-ros/

I do not see where this could be a bug by ROS or catkin, so I tend towards saying that something is wrong with the nootrix distribution of Groovy, and needs to be raised with nootrix.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-31 05:32:38 -0500

Seen: 1,085 times

Last updated: Feb 03 '13