Ask Your Question
0

The updated rgbdslam does not match with g2o?

asked 2013-01-29 23:07:24 -0500

updated 2014-01-28 17:15:02 -0500

ngrennan gravatar image

Let me describe my questions in detail...

I am using fuerte, ubuntu 12.04. We have successfully installed the rgbdslam and openni and octomap in Dec 2012. I made a writeup to summery all the problems we encountered here at http://tianb03.blogspot.sg/2012/12/how-to-successfully-compile.html

Yesterday I have downloaded the latest version of rgbdslam and g2o. I have found that there are some more errors because of the path of the include files related to g2o. So I have searched the forum and found the questions in this link http://answers.ros.org/question/51013/rgbdslam-fixed-for-fuerte-where-do-i-send-the-patch/

This closed questions states a lot of updates for the rgbdslam. I have checked the version I downloaded in Dec 2012 and Jan 2013, the differences are just what has been mentioned in the question. However, I need to change the latest version back to the older version to make the package work.

More Details: Change source file back to an older version according to the markers in the upper link.

in misc.cpp, need to include two more files from opencv. Or else gives some problems on the sift and surf algo..

#if CV_MAJOR_VERSION > 2 || CV_MINOR_VERSION >= 4
#include "opencv2/core/core.hpp"
#include "opencv2/features2d/features2d.hpp"
#include "opencv2/highgui/highgui.hpp"
#include "opencv2/nonfree/nonfree.hpp"

#endif

In CMakeLists.txt, remove the following two lines..

find_package(g2o REQUIRED)
find_package(libg2o REQUIRED)

By the way, I have successfully compiled the latest package. (I think I have changed it back to a previous version already). So I just want to know why it has been changed and is there a way to easily fetch the older working version? Or is there anyway no need to do so many revisions to make the latest version work?

Best regards,

edit retag flag offensive close merge delete

Comments

Please update your post with OS, ROS version, rgbdslam svn revision (svnversion when in the rgbdslam folder), error messages.

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-30 06:48:58 -0500 )edit

3 Answers

Sort by ┬╗ oldest newest most voted
2

answered 2013-02-04 03:18:34 -0500

updated 2013-02-04 22:39:10 -0500

I can't reproduce your problems. It works fine for me. Here is my setup, maybe that helps:

  1. Ubuntu 12.04.1 LTS
  2. The current binary version of ros-fuerte-libg2o (2012.11.09-0precise-20121109-0201-+0000)
  3. Rgbdslam from the repository http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg at the revision 3856 (Which is for the whole alufr repository, rgbdslam was last changed at revision 3802, so everything after 3802 is fine)
  4. Current versions of the libopencv-... binaries (due to an installation of openshot it seems, so maybe unrelated)
  5. ros-fuerte-opencv2, ros-fuerte-vision-opencv
  6. The current binaries for ros-fuerte-octomap, ros-fuerte-octomap-mapping, ros-fuerte-octomap-msgs, ros-fuerte-octomap-ros

I am not sure why it works for me and not for you.

I also do not understand what you mean by

"However, I need to change the latest version back to the older version to make the package work. "

edit flag offensive delete link more

Comments

Thx Felix. I will try to update all the packages you mentioned above. In my configuration, 12.04+Fuerte, not sure about the opencv version. I need to change the files which are "Patched" in the mentioned link. And After that I compiled successfully..

tianb03 gravatar image tianb03  ( 2013-02-04 13:45:20 -0500 )edit
0

answered 2013-01-30 12:25:55 -0500

Apparently RGBDSLAM uses the ROS package libg2o now, however I (and many poeple) could not get it to work with libg2o, so I checked out the g2o package svn co https://svn.openslam.org/data/svn/g2o and changed the dependency in the manifest.xml to <depend package="g2o"/> instead of <!--rosdep name="libg2o"/-->. Make sure to include the g2o package in your ROS PACKAGE PATH.

edit flag offensive delete link more

Comments

Thanks for you comments... Actually I do not have problems in compiling..

tianb03 gravatar image tianb03  ( 2013-01-30 20:22:50 -0500 )edit
0

answered 2013-01-30 21:10:00 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just installed the newest rgbdslam and g2o package. Same as you, I got lots of errors. I resume rgbdslam according to the patch. The problems are almost fixed except one "symbol lookup error": /fuerte_workspace/rgbdslam_freiburg/rgbdslam/lib/libgicp.so: undefined symbol: gsl_multimin_fdfminimizer_vector_bfgs2

I dont know how to fix it.

edit flag offensive delete link more

Comments

I have found one comment by Felix. Could be that you need to deinstall ros-fuerte-libg2o (and rebuild rgbdslam) Felix Endres (Jan 3 '13)

tianb03 gravatar image tianb03  ( 2013-01-31 20:26:24 -0500 )edit

To get mine to work, I had to uninstall ros-fuerte-libg2o and download g2o instead.

K_Yousif gravatar image K_Yousif  ( 2013-02-01 00:22:47 -0500 )edit

I have done these already, uninstall the ros-fuerte-libg2o library, use g2o package, and rebuild. but the problem still exits.

shan333 gravatar image shan333  ( 2013-02-03 04:36:38 -0500 )edit

did you comment the '#find_package(g2o REQUIRED)' in the cmakelist.txt file?

K_Yousif gravatar image K_Yousif  ( 2013-02-03 13:29:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-29 23:07:24 -0500

Seen: 1,124 times

Last updated: Feb 04 '13