Ask Your Question
0

error when compiling humanoid_localization

asked 2013-01-29 05:26:44 -0500

mihota gravatar image

updated 2013-01-29 21:08:45 -0500

AHornung gravatar image

Hi, I am trying to use humanoid_localization for my autonomous underwater vehicle. However I got the error

Could not find module Findoctomap_msgs.cmake or a configuration file for package octomap_msgs

while compiling in ROS fuerte, ubuntu 11.04. Could anyone please help me with this error? Thank you very much.

regards,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-29 21:16:17 -0500

AHornung gravatar image

First question: Are you intentionally using Ubuntu 11.04 with Fuerte, and is 11.04 a requirement? REP-003 states that 11.04 is not a target platform for Fuerte, so you have to compile everything yourself instead of just installing pre-compiled debian packages.

If you check the humanoid_localization Wiki page, you will see a list of dependencies on the right. These ROS packages are required for compiling humanoid_localization, so you need to find their right source versions (e.g. through the Wiki) and compile them as well. Best check the humanoid_navigation stack and install the stacks that it depends on. Now, if you were using Ubuntu 10.04, 11.10, or 12.04 then you could simply install the corresponding debian packages (e.g. sudo apt-get install ros-fuerte-octomap-msgs), otherwise you will have to compile them all from source and add them to your ROS workspace.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-29 05:26:44 -0500

Seen: 494 times

Last updated: Jan 29 '13