Ask Your Question

openni_tracker failed because of InitFromXml failed

asked 2013-01-27 20:25:18 -0600

WIZARD1 gravatar image

Hello ,I am a new user of ROS openni. Now I'm using ubuntu 12.04 and my ROS dist is groovy. when I run the command rosrun openni_tracker openni_tracker,the only thing I got is a error message: InitFromXml failed: Can't create any node of the requested type!

I followed several solutions on the ROS community,still get the same error message

I googled a lot ,but not a correct solution for me.Any help will be appreciated ,It really drives me crazy.

edit retag flag offensive close merge delete


just like this link It won't help

WIZARD1 gravatar imageWIZARD1 ( 2013-01-27 20:26:58 -0600 )edit

Can anybody help me?

WIZARD1 gravatar imageWIZARD1 ( 2013-03-02 02:05:25 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-08-03 20:09:31 -0600

wsAndy gravatar image

You should install install NITE-Bin-Dev, as for me , I install NITE-Bin-Dev-Linux-x64-v1.5.2.21 Then run the in it. Hope it helps.

edit flag offensive delete link more


I have this same error with 14.04 on ROS Indigo. I have downloaded NITE-Bin-Dev-linux-x86-v1.5.2.23 and run the Is there anything else that I can try?

Inder gravatar imageInder ( 2015-11-13 15:40:17 -0600 )edit

You can read this or this one Hope it helps.

wsAndy gravatar imagewsAndy ( 2015-11-13 21:34:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-01-27 20:25:18 -0600

Seen: 929 times

Last updated: Aug 03 '15