eclipse is not using namespace [closed]

asked 2013-01-17 20:52:09 -0500

dinamex gravatar image

updated 2014-01-28 17:14:53 -0500

ngrennan gravatar image

Hi all,

I'm using most of the time eclipse for ROS coding and it worked fine so far. Now I want to use the pcl17 stack but without success in using its namespace. It compiles with cmake but I would like to use autocompletion etc for the development. Did someone else notice that behavior or can help me to solve the problem?

my manifest shows the dependencies to pcl17 and pcl17_ros.

That is my CMakeLists.txt

cmake_minimum_required(VERSION 2.4.6)
include($ENV{ROS_ROOT}/core/rosbuild/rosbuild.cmake)

rosbuild_init()

#set the default path for built executables to the "bin" directory
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
#set the default path for built libraries to the "lib" directory
set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)

find_package(Eigen REQUIRED)
include_directories(${EIGEN_INCLUDE_DIRS})
add_definitions(${EIGEN_DEFINITIONS})

find_package(PCL 1.3 REQUIRED COMPONENTS common io)
include_directories(${PCL_INCLUDE_DIRS})
link_directories(${PCL_LIBRARY_DIRS})
add_definitions(${PCL_DEFINITIONS})

rosbuild_add_boost_directories()
rosbuild_add_executable(mesh_reconstruction src/mesh_reconstruction)
rosbuild_link_boost(mesh_reconstruction system signals)
target_link_libraries(mesh_reconstruction ${PCL_COMMON_LIBRARIES} ${PCL_IO_LIBRARIES})

Is something wrong with my setup? which setting could be wrong in eclipse?

Side question: should/can I delete the standard ros_perception stack (I think its pcl 1.5) after installing pcl17?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-14 16:10:09.429919

Comments

You downloaded and used rosmake if I'm correct yes? Why I have the same problem. I tried to compile it from source but had many problems. Then I downloaded the package that you have but have the same error.

ZsurzsaLaszlo gravatar imageZsurzsaLaszlo ( 2013-06-25 03:26:03 -0500 )edit