ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Openni node can't find device in simulation

asked 2013-01-13 02:09:23 -0500

Albert K gravatar image

Hi everyone:

I try to start the manipulation pipeline following this

First launch pr2_gazebo pr2_table_object.launch

Since I want to use kinect sensor, I launch the pipeline like this:

roslaunch pr2_tabletop_manipulation_launch pr2_tabletop_manipulation.launch stereo:=false

Everything looks good...but at last, it keeps telling me that:

[INFO] [1358084747.016012678, 248.407000000]: [/openni_node1] No devices connected.... waiting for devices to be connected

I trace the launch file and finally find that the pipeline will start the openni-related node from openni_camera_deprecated, which is now replaced by openni_launch.

How could I modify the launch file to make kinect sensor work?

I'm using ROS Fuerte on Ubuntu 12.04

Thanks for any advice~

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2013-01-14 09:53:54 -0500

tfoote gravatar image

Make sure you're setting ROBOT=sim as in the tutorial. It looks like it's trying to connect to the real hardware not the simulated kinect.

edit flag offensive delete link more

answered 2013-01-13 21:02:30 -0500

dbworth gravatar image

The pipeline seems to be designed for an earlier version of the Kinect package.

You want to stop it loading the deprecated Kinect package.

Instead try the openni.launch file, with the driver disabled, as suggested here:

edit flag offensive delete link more

answered 2013-01-15 09:15:15 -0500

Karan gravatar image

You could try appending to the command "load_driver:=false"

I usually do this to generate all topics of Kinect when playing a bag file.

edit flag offensive delete link more

Question Tools


Asked: 2013-01-13 02:09:23 -0500

Seen: 653 times

Last updated: Jan 15 '13