Ask Your Question
1

(Groovy @ 12.04) E: Package 'libtbb-dev' has no installation candidate

asked 2013-01-08 14:10:07 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Am installing ROS Groovy (from source) on a Tablet, whose Kernel is armv7l. When running the command: $ rosdep install --from-paths src --ignore-src --rosdistro groovy -y Items install up until: executing command [sudo apt-get install -y libtbb-dev] as it shows the following error: Reading package lists... Done Building dependency tree Reading state information... Done Package libtbb-dev is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'libtbb-dev' has no installation candidate ERROR: the following rosdeps failed to install apt: command [sudo apt-get install -y libtbb-dev] failed

Any suggestions? If not needed, what other rosdeps exist after this one that the device did not get a chance to install?

Thanks...

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-01-09 00:23:40 -0600

Felix Ruess gravatar image

TBB packages are not built for ARM architectures (not sure if that is even possible/supported).

You can however pass the robust option (-r) to rosdep, and it will continue installing the other dependencies if some packages were not found:

rosdep install --from-paths src --ignore-src --rosdistro groovy -yr

So no need to revert back to installing all dependencies by hand.

edit flag offensive delete link more

Comments

What will break if libtbb-dev and collada-dom-dev failed to install?

corrosion gravatar image corrosion  ( 2013-04-05 10:35:17 -0600 )edit
-1

answered 2013-01-09 04:06:37 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thanks. I ran the following instruction a couple of times

rosdep install --from-paths src --ignore-src --rosdistro groovy -yr

and the only three packages that were not installed were:

libtbb-dev
collada-dom-dev
yaml-cpp

Thanks.

edit flag offensive delete link more
1

answered 2013-01-08 15:51:07 -0600

kalectro gravatar image

updated 2013-01-08 16:21:24 -0600

I tried the same thing on the gumstix and had to find out that rosdep will not work for a not x86 or 64 Bit system because the packages have not been built for your architecture. I went the hard way and installed every dependency by hand. This will by far not be the only missing package!

Kai

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-08 14:10:07 -0600

Seen: 1,928 times

Last updated: Jan 09 '13