Ask Your Question
0

Phidget Interface Kit not being detected

asked 2013-01-03 10:41:03 -0500

joe.s gravatar image

updated 2014-01-28 17:14:43 -0500

ngrennan gravatar image

I have recently attempted to get the phidget interface kit working on a second system... I believe I have followed the same steps as I did before by installing from these links (in to a sandbox directory):

http://mediabox.grasp.upenn.edu/roswiki/phidgetspp_c_api.html 
http://mediabox.grasp.upenn.edu/roswiki/phidgets_py_api.html 
http://mediabox.grasp.upenn.edu/roswiki/phidgets_ros.html#InterfaceKit_ROS_API

All three packages "made" correctly (or at least without errors).

lsusb shows that the interface kit is being read:

Bus 001 Device 005: ID 06c2:0045 Phidgets Inc. (formerly GLAB) PhidgetInterface Kit 8-8-8

However, when running "roslaunch phidgets_ros interface_kit.launch", I receive this error:

[WARN] [WallTime: 1357252527.824527] No serial number specified. This node will connect to the first interface kit attached.

I have tested the interface kit itself on a known working system, and it seems to function just fine. It seems that for some reason, the interface kit is not being detected or picked up on the second system.

Any suggestions would be appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-03 23:44:49 -0500

davinci gravatar image

The phidgets use a serial number which is used for communication. With lsusb -v you can see this. This number should probably be changed in the launch file (the documentation is not clear about this). interface_kit/<device_serial_number or="" user_defined_name="">/sensor/<port_number>

edit flag offensive delete link more

Comments

This is the code for the launch file:

<launch>
<node name="interface_kit" pkg="phidgets_ros" type="interface_kit.py" output="screen">
    <!-- <param name="name" type="str" value="my_interface_kit"/> -->

<!-- <param name="serial_number" type="int" value="96952"/>--> </node> </launch>

joe.s gravatar image joe.s  ( 2013-01-04 04:20:07 -0500 )edit

The serial number of the device is 116807... when I un-comment and change the launch file to this: <param name="serial_number" type="int" value="-1"/>--> </node> </launch> I get an error stating

joe.s gravatar image joe.s  ( 2013-01-04 04:39:27 -0500 )edit

Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored process[interface_kit-1]: started with pid [14487]

joe.s gravatar image joe.s  ( 2013-01-04 04:40:12 -0500 )edit

But, the interface kit (physical device) is actually attached. I also made this modification on the known working machine and it works just fine there... any suggestions?

joe.s gravatar image joe.s  ( 2013-01-04 04:50:44 -0500 )edit

Did you change the rights on the usb port? There is a udev rule in the phidgets software package, if I remember it correctly.

davinci gravatar image davinci  ( 2013-01-04 06:40:43 -0500 )edit

Apparently that was it. I had to re-run this line: export USB_DEVFS_PATH=/dev/bus/usb Thank you!

joe.s gravatar image joe.s  ( 2013-01-04 07:45:02 -0500 )edit
0

answered 2013-01-04 07:45:48 -0500

joe.s gravatar image

Had to re-run export USB_DEVFS_PATH=/dev/bus/usb in order to have the proper settings for the USB.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-03 10:41:03 -0500

Seen: 1,066 times

Last updated: Jan 04 '13