Ask Your Question
6

Unmet dependencies for Groovy on Ubuntu 12.10

asked 2012-12-31 21:02:54 -0600

amine23 gravatar image

updated 2013-01-03 14:08:32 -0600

Kevin gravatar image

Hi,

I have a problem with Groovy install on Ubuntu 12.10. When I type

sudo apt-get install ros-groovy-desktop-full

I get :

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-desktop-full : Depends: ros-groovy-ros-tutorials (= 0.3.9-0quantal-20121230-1232-+0000) but it is not going to be installed
                           Depends: ros-groovy-nodelet-core (= 1.7.13-0quantal-20121230-1911-+0000) but it is not going to be installed
                           Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1356945732~quantal) but it is not going to be installed
                           Depends: ros-groovy-geometry-tutorials (= 0.1.3-s1356894174~quantal) but it is not going to be installed
                           Depends: ros-groovy-orocos-kinematics-dynamics (= 0.2.3-s1356865696~quantal) but it is not going to be installed
                           Depends: ros-groovy-filters (= 1.6.0-s1356894312~quantal) but it is not going to be installed
                           Depends: ros-groovy-slam-gmapping (= 1.2.7-s1356944956~quantal) but it is not going to be installed
                           Depends: ros-groovy-ros (= 1.9.39-0quantal-20121230-1040-+0000) but it is not going to be installed
                           Depends: ros-groovy-qt-gui-core (= 0.2.9-0quantal-20121230-1144-+0000) but it is not going to be installed
                           Depends: ros-groovy-vision-opencv (= 1.9.14-0quantal-20121230-2323-+0000) but it is not going to be installed
                           Depends: ros-groovy-perception-pcl (= 1.0.24-0quantal-20121230-1955-+0000) but it is not going to be installed
                           Depends: ros-groovy-rqt-common-plugins (= 0.2.7-0quantal-20121231-2005-+0000) but it is not going to be installed
                           Depends: ros-groovy-actionlib (= 1.9.11-0quantal-20121230-1206-+0000) but it is not going to be installed
                           Depends: ros-groovy-pluginlib (= 1.9.17-0quantal-20121230-1110-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-pipeline (= 1.9.11-0quantal-20121230-2354-+0000) but it is not going to be installed
                           Depends: ros-groovy-bfl (= 0.1.0-s1356865809~quantal) but it is not going to be installed
                           Depends: ros-groovy-stage (= 1.6.7-s1356894745~quantal) but it is not going to be installed
                           Depends: ros-groovy-rqt-robot-plugins (= 0.2.7-0quantal-20121231-2000-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-common (= 1.9.22-0quantal-20121230-1342-+0000) but it is not going to be installed
                           Depends: ros-groovy-bond-core (= 1.7.9-0quantal-20121230-1142-+0000) but it is not going to be installed
                           Depends: ros-groovy-common-tutorials (= 0.2.3-s1356896830~quantal) but it is not going to be installed
                           Depends: ros-groovy-ros-comm (= 1.9.39-0quantal-20121230-1801-+0000) but it is not going to be installed
                           Depends: ros-groovy-physics-ode (= 1.8.0-s1356864560~quantal) but it is not going to be installed
                           Depends: ros-groovy-driver-common (= 1.6.4-0quantal-20121230-1912-+0000) but it is not going to be installed
                           Depends: ros-groovy-executive-smach (= 1.2.0-s1356894288~quantal) but it is not going to be installed
                           Depends: ros-groovy-common-msgs (= 1.9.11-0quantal-20121225-1907-+0000) but it is not going to be installed
                           Depends: ros-groovy-dynamic-reconfigure (= 1.5.29-0quantal-20121230-1449-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-transport-plugins (= 1.8.15-0quantal-20121230-2344-+0000) but it is not going to be installed
                           Depends: ros-groovy-xacro (= 1.6.1-s1356894606~quantal) but it is not going to be installed
                           Depends: ros-groovy-robot-model (= 1.9.32-0quantal-20121230-1900-+0000) but it is not going to be installed
                           Depends: ros-groovy-bullet (= 2.80-s1356864740 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Please make sure you have done an apt-get update recently. And then try to narrow down exactly which package is failng. Apt is bad in that it just tells you something is failing, not which specific package is failing.

tfoote gravatar imagetfoote ( 2013-01-02 13:06:22 -0600 )edit

Thanks, but I did the apt-get update. What is a good way to do so ?

amine23 gravatar imageamine23 ( 2013-01-02 23:07:12 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-08 03:36:46 -0600

amine23 gravatar image

I did install it using aptitude, by installing / downgrading the dependencies one by one.

edit flag offensive delete link more

Comments

could you share more details on the use of aptitude? is it a time consuming work? should I be better downgrade my Linux to Precise? Thank you!

roskidos gravatar imageroskidos ( 2014-03-12 21:37:08 -0600 )edit

You don't need to downgrade you Ubuntu to precise. 13.04 should work fine. Aptitude would give you more details on the required packages (and their versions). So you can install the package if it is missing, or downgrade to the required version by typing: sudo aptitude install pkg=version.

amine23 gravatar imageamine23 ( 2014-03-13 11:50:38 -0600 )edit
1

answered 2013-01-08 05:37:14 -0600

Dirk Thomas gravatar image

You should try sudo apt-get update && sudo apt-get dist-upgrade. That will force all packages to be updated and might ask you to remove packages which dependencies are not met anymore.

edit flag offensive delete link more
0

answered 2013-02-01 00:15:45 -0600

jon_ross gravatar image

updated 2013-02-01 00:22:04 -0600

Make sure you have the additional repositories for universe and multiverse. Here is the relevant part from my /etc/apt/sources.list (I can't post links yet due to insufficient karma):

deb http://yourUbuntuDebServer quantal main restricted universe multiverse
deb-src http://yourUbuntuDebServer quantal main restricted universe multiverse

A simple

apt-get update
apt-get install ros-groovy-desktop-full

should install everything.

edit flag offensive delete link more
0

answered 2013-01-11 02:12:14 -0600

updated 2013-01-11 02:18:44 -0600

I had the same problem with a fresh installed system.

Tracing many unmet dependencies I ended up installing libavutil51 (and friends).

After that the install of ros-groovy-desktop is running without problems.

Have not tried -full, but I trust that will work also.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-31 21:02:54 -0600

Seen: 1,321 times

Last updated: Feb 01 '13