Ask Your Question
0

Problems installing Gazebo

asked 2012-12-30 06:34:50 -0500

jdd gravatar image

I'm trying to install Gazebo but running into the following errors. I think it has something to do with trying to update Ubuntu. This is with 12.04 and Fuerte.

turtlebot@turtlebot-Aspire-5552:~$ sudo apt-get install ros-fuerte-simulator-gazebo Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: ros-fuerte-desktop-full : Depends: ros-fuerte-simulator-gazebo (= 1.6.12-s1344941223~precise) but 1.6.16-s1347172830~precise is to be installed ros-fuerte-simulator-gazebo : Depends: ros-fuerte-bullet (= 2.79-s1347124289~precise) but 2.79-s1344803197~precise is to be installed Depends: ros-fuerte-common-msgs (= 1.8.13-0precise-20120908-1740-+0000) but 1.8.13-0precise-20120812-0100-+0000 is to be installed Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1347122840~precise) but 1.2.0-s1344802959~precise is to be installed Depends: ros-fuerte-driver-common (= 1.4.0-s1347168681~precise) but 1.4.0-s1344802685~precise is to be installed Depends: ros-fuerte-geometry (= 1.8.2-s1347128281~precise) but 1.8.2-s1344803881~precise is to be installed Depends: ros-fuerte-image-common (= 1.8.0-s1347133482~precise) but 1.8.0-s1344804269~precise is to be installed Depends: ros-fuerte-nodelet-core (= 1.6.5-s1347168835~precise) but 1.6.5-s1344806081~precise is to be installed Depends: ros-fuerte-perception-pcl (= 1.2.3-s1347170256~precise) but 1.2.2-s1344806759~precise is to be installed Depends: ros-fuerte-robot-model (= 1.8.1-s1347133837~precise) but 1.8.1-s1344897545~precise is to be installed Depends: ros-fuerte-ros (= 1.8.10-0precise-20120908-1636-+0000) but 1.8.10-0precise-20120811-2208-+0000 is to be installed Depends: ros-fuerte-ros-comm (= 1.8.15-0precise-20120908-1740-+0000) but 1.8.15-0precise-20120812-0102-+0000 is to be installed Depends: ros-fuerte-visualization-common (= 1.8.4-s1347128602~precise) but 1.8.4-s1344815737~precise is to be installed Depends: ros-fuerte-xacro (= 1.6.1-s1347128571~precise) but 1.6.1-s1344809708~precise is to be installed Depends: ros-fuerte-protobuf (= 0.1.0-s1347128313~precise) but 0.1.0-s1344835219~precise is to be installed turtlebot-env : Depends: turtlebot-ros E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

edit retag flag offensive close merge delete

Comments

Have you tried 'apt-get -f install'?

Alexandr Buyval gravatar image Alexandr Buyval  ( 2012-12-30 18:58:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-12-30 19:05:50 -0500

Alexandr Buyval gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-30 06:34:50 -0500

Seen: 68 times

Last updated: Dec 30 '12