Issues launching openni_kinect in ubuntu 11.10 [closed]

asked 2012-12-25 09:45:29 -0500

metal gravatar image

updated 2012-12-26 08:43:24 -0500

Hello everyone, I have been working with the RGB-D camera asus xtion pro live on ubuntu 11.04 for some time,it was working well with openni_kinect package. I wanted to use PCL(Point Cloud Library) with the sensor for a particular project. In order to fix a certain bug in PCL installation,I upgraded my system to 64-bit Ubuntu 11.10.

After the upgrade ,I ran the launch file and here is the output.

 $roslaunch openni_launch openni.launch 
... logging to /home/karthik/.ros/log/d7b70e78-4eda-11e2-8790-58946b8cfcc8/roslaunch-karthik-laptop-6871.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
WARNING: disk usage in log directory [/home/karthik/.ros/log] is over 1GB.
It's recommended that you use the 'rosclean' command.

started roslaunch server http://karthik-laptop:32863/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /camera/driver/rgb_frame_id
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/rgb_camera_info_url
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/driver/depth_frame_id
 * /camera/depth/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /rosversion
 * /camera/driver/device_id
 * /camera/driver/depth_camera_info_url
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range

NODES
  /camera/depth/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)
    points (nodelet/nodelet)
  /camera/rgb/
    debayer (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
  /
    camera_nodelet_manager (nodelet/nodelet)
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
  /camera/
    driver (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    rectify_depth (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    metric (nodelet/nodelet)

auto-starting new master
process[master]: started with pid [6885]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to d7b70e78-4eda-11e2-8790-58946b8cfcc8
process[rosout-1]: started with pid [6898]
started core service [/rosout]
process[camera_nodelet_manager-2]: started with pid [6910]
process[camera/driver-3]: started with pid [6911]
process[camera/rgb/debayer-4]: started with pid [6912]
process[camera/rgb/rectify_mono-5]: started with pid [6913]
process[camera/rgb/rectify_color-6]: started with pid [6919]
process[camera/ir/rectify_ir-7]: started with pid [6933]
process[camera/depth/rectify_depth-8]: started with pid [6935]
process[camera/depth/metric_rect-9]: started with pid [6939]
process[camera/depth/metric-10]: started with pid [6950]
process[camera/depth/points-11]: started with pid [6963]
process[camera/register_depth_rgb-12]: started with pid [6976]
process[camera/depth_registered/rectify_depth-13]: started with pid [6987]
process[camera/depth_registered/metric_rect-14]: started with pid [7012]
process[camera/depth_registered/metric-15]: started with pid [7016]
process[camera/points_xyzrgb_depth_rgb-16]: started with pid [7031]
process[camera/disparity_depth-17]: started with pid [7039]
process[camera/disparity_depth_registered-18]: started with pid [7048]
process[camera_base_link-19]: started with pid [7060]
process[camera_base_link1-20]: started with pid [7070]
process[camera_base_link2-21]: started with pid [7074]
process[camera_base_link3-22]: started with pid [7075]
[rospack] warning: ignoring duplicate "nodelet" tag in export block
[ERROR] [1356471268.471142550]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters]
[ERROR] [1356471268.482664732]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]
[ERROR] [1356471269.530417421]: Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: Failed to load library /opt/ros/electric/stacks/openni_kinect/openni_camera/lib/libopenni_nodelet.so. Make sure that ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-10-28 00:00:06.875489

Comments

is the /opt/ros/electric/stacks/openni_kinect/openni_camera/lib/libopenni_nodelet.so there?

dinamex gravatar imagedinamex ( 2012-12-26 13:29:51 -0500 )edit

thanks for the reply. Yes its there. I checked it.

metal gravatar imagemetal ( 2012-12-27 13:17:36 -0500 )edit