Ask Your Question
1

RGBDSLAM error: Trust certificate g2o problem

asked 2012-12-18 12:27:33 -0500

updated 2014-01-28 17:14:37 -0500

ngrennan gravatar image

Hey guys,

I am using ubuntu 12.04 and ros fuerte. I am trying to run rgbdslam.

I followed the instructions given in this post http://answers.ros.org/question/50585/rgbdslam-error-in-fuerte-and-electric/ (link text): and I got the following error:

svn --non-interactive --config-dir /home/samme/trunk/g2o/svnconf co https://svn.openslam.org/data/svn/g2o/trunk build/g2o svn: OPTIONS of 'https://svn.openslam.org/data/svn/g2o/trunk': Server certificate verification failed: issuer is not trusted (https://svn.openslam.org)

Note: I had previously downloaded g2o from the svn: https://openslam.informatik.uni-freiburg.de/data/svn/g2o/trunk/. I then moved the file trunk to the rubbish bin and downloaded g2o again from the svn : https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/

I have been told to add the line: SVN_CMDLINE = svn--trust-server-cert--non-interactive --config-dir $(TOP_DIR)/svnconf to the makefile in the g2o folder.

However I am now getting this error:

svn--trust-server-cert--non-interactive --config-dir /home/samme/trunk/g2o/svnconf co https://svn.openslam.org/data/svn/g2o/trunk build/g2o make: svn--trust-server-cert--non-interactive: Command not found

Am I doing the command correctly? I really appreciate your help.

Regards,

Khalid

edit retag flag offensive close merge delete

Comments

I resolved this issue (the answer below), I have another problem, I will post it on a new thread.

K_Yousif gravatar image K_Yousif  ( 2012-12-18 12:42:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-12-18 12:41:13 -0500

The solution to this problem is adding this line: SVN_CMDLINE = svn --no-auth-cache --trust-server-cert --non-interactive instead of the one I mentioned earlier.

Regards,

Khalid

edit flag offensive delete link more

Comments

1

The author commented the wrong one I think. We encountered the same prob yesterday.

tianb03 gravatar image tianb03  ( 2012-12-18 18:24:57 -0500 )edit

This does not work for me. The line is already in the Makefile.

ZiyangLI gravatar image ZiyangLI  ( 2014-01-12 20:38:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-12-18 12:27:33 -0500

Seen: 631 times

Last updated: Dec 18 '12