Ask Your Question
1

RGBDSLAM Crashes

asked 2012-12-17 12:57:31 -0500

tgaaly gravatar image

updated 2014-01-28 17:14:36 -0500

ngrennan gravatar image

I followed the steps to install rgbdslam on ROS fuerte by installing g2o separately and changing the manifest and CMakefiles...etc.

Now when I execute rgbdslam (kinect+rgbdslam.launch) the UI pops up and the rgb and depth feeds are shown.

When I click on space or select "process" from the menu, it crashes.

I get the following error:

================================================================================REQUIRED process [rgbdslam-23] has died!
process has died [pid 16367, exit code -11, cmd /home/asctec/ros_workspace/rgbdslam_freiburg/rgbdslam/bin/rgbdslam __name:=rgbdslam __log:=/home/asctec/.ros/log/ec9ae076-48a9-11e2-af27-000e8e31444e/rgbdslam-23.log].
log file: /home/asctec/.ros/log/ec9ae076-48a9-11e2-af27-000e8e31444e/rgbdslam-23*.log
Initiating shutdown!
================================================================================

The log file is not actually stored so Im not sure whats going on under the hood. Im running this on ubuntu 12.04 with ROS Fuerte

Does anyone know why this happens?

edit retag flag offensive close merge delete

Comments

Hi, we are stuck at the g2o installation. Can you explain in detail what does it mean "installing g2o seperately"? using 'svn co https://svn.openslam.org/data/svn/g2o' from open slam or 'svn https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk' from ros.org?

tianb03 gravatar image tianb03  ( 2012-12-17 22:19:14 -0500 )edit

I used https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk. Then faced a problem: "certificate verification failed: issuer is not trusted". I resolved this by editing the makefile & added '--trust-serve-cert' b4 '--non-interactive'. Then ran rosmake. Took a while but I was able to run-but crashed

tgaaly gravatar image tgaaly  ( 2012-12-18 00:21:36 -0500 )edit

Thanks. We recompiled the g2o, same error as we use the libg2o when rosmake the rgbdslam. Don't know how.. configuration incomplete error

tianb03 gravatar image tianb03  ( 2012-12-18 18:33:37 -0500 )edit

did u uninstall libg2o first?

tgaaly gravatar image tgaaly  ( 2012-12-19 11:33:37 -0500 )edit

Hi tgaaly, thanks for your help. We have made it. I wrote down all the problems encountered by us http://tianb03.blogspot.sg/2012/12/how-to-successfully-compile.html. Hope you can have a look. I hope it can help the others who want to install rgbdslam.

tianb03 gravatar image tianb03  ( 2012-12-19 16:04:25 -0500 )edit

no problem. Does the 3D reconstruction of rgbdslam work with you? I have tried for quite some time to get it working but there seems to be issues due to changes between openni fuerte and openni electric. The rgb & depth feeds are working fine but no 3D point clouds are shown in the top black screen

tgaaly gravatar image tgaaly  ( 2012-12-19 19:48:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-12-18 19:32:04 -0500

tgaaly gravatar image

updated 2012-12-18 19:34:39 -0500

figured it out. The feature detector and extractor was set to SIFTGPU in the kinect+rgbdslam.launch file. I do not have a GPU for this execute. This was causing a segmentation fault. I switched to SURF features and its working

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-12-17 12:57:31 -0500

Seen: 838 times

Last updated: Dec 18 '12