ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

interactive_marker execution error

asked 2012-12-03 04:24:49 -0500

nufa gravatar image

Hello; After I've tried to create the interactive_markers package and copied all the folders from the source which are needed for the package from interactive_markers for electric. I got an error when I tried to build the package which is running the rosmake for this package. The error is:

~ros/interactive_markers/src/interactive_marker_server.cpp:431: error: ‘visualization_msgs’ has not been declared ...

There are some other errors which is kind of related to the interactive_marker_server.cpp, but I do not paste it here.

So, what I wanna ask here, as it seems the package is new in electric, someone might have encountered this. Could anyone help me on this?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-06-17 13:01:02 -0500

tfoote gravatar image

The error suggests you are missing some includes which include "visualization_msgs". You'll need to provide more information to get more help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-12-03 04:24:49 -0500

Seen: 139 times

Last updated: Jun 17 '13