Ask Your Question
0

Compilation error ROS_PACKAGE_PATH in groovy

asked 2012-11-28 05:41:28 -0500

jrcapriles gravatar image

updated 2014-01-28 17:14:25 -0500

ngrennan gravatar image

Hi all,

I recently installed groovy. I'm trying to rosmake my packages but I getting this error all the time:

[ rosmake ] All 19 linestutorial_package: 0.1 sec ] 
{-------------------------------------------------------------------------------
  mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/groovy/share/ros/core/rosbuild/rostoolchain.cmake  ..
  [rosbuild] Building package range_gazebo_plugin
  including user's config file: /opt/ros/groovy/share/ros/rosconfig.cmake
  -- USING OPTIMIZATION COMPILATION FLAGS: -mssse3 -mmmx 
  CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/private.cmake:99 (message):
    [rosbuild] rospack found package "tutorial_package" at
    "/home/jose/ros-workspace/tutorial_package",
    but the current directory is
    "/home/jose/ros-workspace/tutorial_package".
    You should double-check your ROS_PACKAGE_PATH to ensure that packages are
    found in the correct precedence order.
  Call Stack (most recent call first):
    /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:177 (_rosbuild_check_package_location)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}

My environment variables:

declare -x ROS_DISTRO="groovy"
declare -x ROS_ETC_DIR="/opt/ros/groovy/etc/ros"
declare -x ROS_LOG_DIR="/home/josecapriles/.ros/logs"
declare -x ROS_MASTER_URI="http://localhost:11311"
declare -x ROS_PACKAGE_PATH="/home/jose/ros-workspace:/opt/ros/groovy/share:/opt/ros/groovy/stacks"
declare -x ROS_ROOT="/opt/ros/groovy/share/ros"
declare -x ROS_WORKSPACE="/home/jose/ros-workspace"

I'm running ROS groovy on Ubuntu 12.04. Any idea what is missing in the environment configuration? or why rosmake complains about the ROS_PACKAGE_PATH?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-11-28 11:18:23 -0500

allenh1 gravatar image

I'm not too familiar with the declare command, so I'm just going to tell you what works for me. I encountered the same issue... All I had to do was add this to my ~/.bashrc file:

export ROS_PACKAGE_PATH=/home/jose/ros-workspace:$ROS_PACKAGE_PATH
edit flag offensive delete link more

Comments

Thanks for your answer! that was my first thought. But I checked and I have the ROS_PACKAGE_PATH well set. The declare -x is what you see if you execute "export | grep ROS"

jrcapriles gravatar imagejrcapriles ( 2012-11-28 21:28:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-28 05:41:28 -0500

Seen: 2,119 times

Last updated: Nov 28 '12