Ask Your Question
1

can't record cloud points

asked 2012-11-20 10:19:53 -0600

salma gravatar image

Hi,i am trying to record object model using Roboearth stack firstly , i set up my enviroment kinect and marker then, opened openni launch for the kinect and enabled depth_registeration after that i begin to rosrun re_object_recorder record_gui

and the gui opened but can't recieved any cloud points !!

maker detected well and light is fine like in pictures below i decreased distance of marker in gui but still no recieved any cloud point !!

any help ??

image description

image description

and rviz can't recieve any cloud point too !

edit retag flag offensive close merge delete

Comments

1

I don't know the visualization tool you are using, but did you try to simply zoom out? From the images you posted I see few spare points, maybe the cloud is too large to fit the screen.

Saphrosit gravatar imageSaphrosit ( 2012-11-20 21:11:30 -0600 )edit

No these spare points are boundry box points not cloud points

salma gravatar imagesalma ( 2012-11-21 11:08:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-11-20 21:26:26 -0600

ddimarco gravatar image

It admittedly takes a bit of experience to find a working setup. Take a look at these hints.

Seeing your picture, I suggest to make sure that the marker pattern is completely planar. If all fails, you can adjust the 'marker_dist_threshold' parameter as described in the page linked above.

edit flag offensive delete link more

Comments

@ddimarco thanks !,,,

salma gravatar imagesalma ( 2012-11-21 11:29:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-20 10:19:53 -0600

Seen: 94 times

Last updated: Nov 20 '12