Cannot get rosdep.yaml to work properly under Electric [closed]

asked 2012-11-19 03:19:27 -0500

Pi Robot gravatar image

Hello,

I am following these rosdep instructions for a package I have written under ROS Electric and Ubuntu 11.10 (Oneric) and I can't get it to work as advertised. For example, if I use the following rosdep.yaml file:

pyserial:
  ubuntu:
    11.10: |
      echo "Attempting to upgrade PySerial..."
      sudo pip install --upgrade pyserial

and run

$ rosdep install package_name

I get the following on the screen:

No installers found for rosdep [pyserial], OS version [oneiric].  Rule:
{{{
{'11.10': 'echo "Attempting to upgrade PySerial..."\nsudo pip install --upgrade pyserial\n'}
}}}

All required rosdeps installed successfully

So it appears that neither the echo command nor the pip install is actually being run. What am I doing wrong?

--patrick

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-12-21 08:18:45

Comments

Maybe you are running rosdep2 by accident. What does which rosdep print?

joq gravatar imagejoq ( 2012-11-24 03:16:50 -0500 )edit

Hi @joq. Running 'which rosdep' yields: /opt/ros/electric/ros/bin/rosdep

Pi Robot gravatar imagePi Robot ( 2012-11-25 03:07:27 -0500 )edit

That looks correct. The bash script "|" syntax should still be supported for Electric (but not for Fuerte): http://ros.org/reps/rep-0111.html#bash-scripts

joq gravatar imagejoq ( 2012-11-26 12:41:18 -0500 )edit

@Pi Robot did you resolve this? One thing I note is that it's comparing 11.10 to oneiric. For a while we supported both codename and version numbers but we moved to just codenames at some point.

tfoote gravatar imagetfoote ( 2013-02-04 17:16:55 -0500 )edit

@tfoote No, I have not resolved this but it is not longer so important to me since I no longer have Electric on any machine to try it out. So feel free to close this question.

Pi Robot gravatar imagePi Robot ( 2013-02-07 02:47:29 -0500 )edit