Ask Your Question
0

Problem loading cram_physics_utils

asked 2012-11-15 01:46:03 -0500

ZiyangLI gravatar image

updated 2012-11-21 03:33:20 -0500

Hi, when I try to load some asd files in rosemacs I encounter the following problem. No idea how to solve, need help!!!

; g++ -m64 -I/opt/ros/fuerte/include -I/opt/ros/fuerte/stacks/cram_core/3rdparty/cffi/cffi-dev/ -o ~/.cache/common-lisp/sbcl-1.0.50-linux-amd64~/ros/fuerte_workspace/stable_stacks/cram_highlevel/cram_physics_utils/src/assimp-grovel ~/.cache/common-lisp/sbcl-1.0.50-linux-amd64~/ros/fuerte_workspace/stable_stacks/cram_highlevel/cram_physics_utils/src/assimp-grovel.c
; 
; compilation unit aborted
;   caught 1 fatal ERROR condition

I am using Fuerte on Ubuntu10.04X64, cram_highlevel is cloned yesterday.

contents of the inferior-lisp

> STYLE-WARNING:
>   Implicitly creating new generic function STREAM-READ-CHAR-WILL-HANG-P.
>; loading #P"~/.slime/fasl/2012-06-19/sbcl-1.0.50-linux-x86-64/swank-match.fasl"
>; loading #P"~/.slime/fasl/2012-06-19/sbcl-1.0.50-linux-x86-64/swank-rpc.fasl"
>; loading #P"~/.slime/fasl/2012-06-19/sbcl-1.0.50-linux-x86-64/swank.fasl"
>WARNING: These Swank interfaces are unimplemented:
> (DISASSEMBLE-FRAME SLDB-BREAK-AT-START SLDB-BREAK-ON-RETURN)


>; file: ~/.swank.lisp
>; in: SETF SWANK:*GLOBALLY-REDIRECT-IO*
>;     (SETF SWANK:*GLOBALLY-REDIRECT-IO* T)
>; ==>
>;   (SETQ SWANK:*GLOBALLY-REDIRECT-IO* T)
>; 
>; caught WARNING:
>;   undefined variable: SWANK:*GLOBALLY-REDIRECT-IO*
>; 
>; compilation unit finished
>;   Undefined variable:
>;     SWANK:*GLOBALLY-REDIRECT-IO*
>;   caught 1 WARNING condition
>;; Swank started at port: 57838.
57838
>* STYLE-WARNING: redefining SWANK::SYMBOL-INDENTATION in DEFUN
STYLE-WARNING: redefining SWANK::MACRO-INDENTATION in DEFUN

Debug window

Component "" not found
   [Condition of type ASDF:MISSING-COMPONENT]

Restarts:
 0: [ABORT] Abort compilation.
 1: [*ABORT] Return to SLIME's top level.
 2: [TERMINATE-THREAD] Terminate this thread (#<THREAD "new-repl-thread" RUNNING {100305B5C1}>)

Backtrace:
  0: ((LAMBDA ()))
  1: ((LAMBDA ()))
      [No Locals]
  2: (ASDF::CALL-WITH-SYSTEM-DEFINITIONS #<CLOSURE (LAMBDA #) {100323AB19}>)
  3: ((SB-PCL::FAST-METHOD ASDF:OPERATE (T T)) #<unused argument> #<unused argument> ASDF:LOAD-OP "")
  4: ((SB-PCL::EMF ASDF:OPERATE) #<unused argument> #<unused argument> ASDF:LOAD-OP "")
  5: ((LAMBDA ()))
  6: ((FLET SWANK-BACKEND:CALL-WITH-COMPILATION-HOOKS) #<CLOSURE (LAMBDA #) {100323AA99}>)
  7: (SWANK::OPERATE-ON-SYSTEM "" SWANK-IO-PACKAGE::LOAD-OP)
  8: ((LAMBDA ()))
  9: (SWANK::MEASURE-TIME-INTERVAL #<CLOSURE (LAMBDA #) {100323A9D9}>)
 10: (SWANK::COLLECT-NOTES #<CLOSURE (LAMBDA #) {100323A9A9}>)
 11: (SB-INT:SIMPLE-EVAL-IN-LEXENV (SWANK:OPERATE-ON-SYSTEM-FOR-EMACS "" (QUOTE SWANK-IO-PACKAGE::LOAD-OP)) #<NULL-LEXENV>)
 12: (EVAL (SWANK:OPERATE-ON-SYSTEM-FOR-EMACS "" (QUOTE SWANK-IO-PACKAGE::LOAD-OP)))
 13: (SWANK:EVAL-FOR-EMACS (SWANK:OPERATE-ON-SYSTEM-FOR-EMACS "" 'SWANK-IO-PACKAGE::LOAD-OP) "COMMON-LISP-USER" 29)
 14: (SWANK::PROCESS-REQUESTS NIL)
 15: ((LAMBDA ()))
 16: ((LAMBDA ()))
 17: (SWANK-BACKEND::CALL-WITH-BREAK-HOOK #<FUNCTION SWANK:SWANK-DEBUGGER-HOOK> #<CLOSURE (LAMBDA #) {1003060119}>)
 18: ((FLET SWANK-BACKEND:CALL-WITH-DEBUGGER-HOOK) #<FUNCTION SWANK:SWANK-DEBUGGER-HOOK> #<CLOSURE (LAMBDA #) {1003060119}>)
 19: (SWANK::CALL-WITH-BINDINGS ((*STANDARD-OUTPUT* . #) (*STANDARD-INPUT* . #) (*TRACE-OUTPUT* . #) (*ERROR-OUTPUT* . #) (*DEBUG-IO* . #) (*QUERY-IO* . #) ...) #<CLOSURE (LAMBDA #) {1003060139}>)
 20: (SWANK::HANDLE-REQUESTS #<SWANK::MULTITHREADED-CONNECTION {1003B98CC1}> NIL)
 21: ((FLET #:WITHOUT-INTERRUPTS-BODY-[BLOCK414]419))
 22: ((FLET SB-THREAD::WITH-MUTEX-THUNK))
 23: ((FLET #:WITHOUT-INTERRUPTS-BODY-[CALL-WITH-MUTEX]301))
 24: (SB-THREAD::CALL-WITH-MUTEX ..)
 25: (SB-THREAD::INITIAL-THREAD-FUNCTION)
 26: ("foreign function: call_into_lisp")
 27: ("foreign function: new_thread_trampoline")

New problem after the patch, when I load cram_plan_library

; compiling file "~/ros/fuerte_workspace/stable_stacks/cram_highlevel/cram_plan_library/src/at-location.lisp" (written 14 NOV 2012 01:44:02 PM):
; compiling (IN-PACKAGE :PLAN-LIB)
; compiling (DEFVAR *AT-LOCATION-LOCK* ...)
; compiling (DEFCONSTANT +AT-LOCATION-RETRY-COUNT+ ...)
; compiling (CRAM-PROJECTION:DEFINE-SPECIAL-PROJECTION-VARIABLE *AT-LOCATION-LOCK* ...)
; compiling (DEFUN LOCATION-DESIGNATOR-REACHED ...)
; compiling (DEFMACRO WITH-EQUATE-FLUENT ...)
;
; compilation aborted because of fatal error:
;   SB-INT:SIMPLE-READER-PACKAGE-ERROR at 3626 (line 75, column 45) on #<SB-SYS:FD-STREAM
;                                                                        for "file ~/ros/fuerte_workspace/stable_stacks/cram_highlevel/cram_plan_library/src/at-location.lisp"
;                                                                        {10044AC5E1}>:
;     Symbol "WITH-TRANSFORMS-CHANGED-CALLBACK" not found in the CL-TF package.
;   
; compilation aborted after 0:00:00.057
WARNING:
   COMPILE-FILE warned while performing #<COMPILE-OP NIL {1003BAB741}> on
   #<CL-SOURCE-FILE "cram-plan-library" "src" "at-location">.
; 
; compilation unit aborted
;   caught 2 fatal ERROR conditions
edit retag flag offensive close merge delete

Comments

Is this really the complete output after the error occurred? To improve readability (newlines don't seem to be displayed correctly), can you please change the formatting of your code from citation to code? Just mark the code and press Ctrl-k.

Lorenz gravatar imageLorenz ( 2012-11-15 02:36:09 -0500 )edit

Ok. More questions :) For me, the inferior-lisp buffer doesn't really show anything useful. But since you got a compilation error, I guess emacs entered the debugger. Can you please provide the contents of the debugger window? It should contain the actual compiler error message.

Lorenz gravatar imageLorenz ( 2012-11-15 02:47:29 -0500 )edit

The error message above doesn't seem to be related to assimp. It rather looks like you tried to load an asdf file with name "".

Lorenz gravatar imageLorenz ( 2012-11-15 02:56:19 -0500 )edit

Thank you Lorenz, your patch indeed works!

ZiyangLI gravatar imageZiyangLI ( 2012-11-15 03:00:26 -0500 )edit

Your second issue is completely unrelated to cram_physics_utils. Please open a new question and re-mark my answer as correct if it was. I will answer there.

Lorenz gravatar imageLorenz ( 2012-11-15 03:18:02 -0500 )edit

Done, thanks!

ZiyangLI gravatar imageZiyangLI ( 2012-11-15 03:31:24 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2012-11-15 01:56:26 -0500

Lorenz gravatar image

updated 2012-11-15 02:54:55 -0500

My guess is that you do not have assimp installed. I just added the corresponding rosdep rule and pushed it to cram_highlevel. Try installing it with:

sudo apt-get install libassimp-dev

If that doesn't help, please edit your answer to provide more information. Please provide more lines around the actual error, maybe it contains something useful that helps debugging the problem. Also, please provide information such as the ROS version you are using and the version of Ubuntu and make sure you have a look at the support page.

Update: Do you maybe have openrave installed? Its requires version 3 of assimp which unfortunately conflicts with version 2 provided by Ubuntu and used by ROS Fuerte. If you need to use assimp3, apply the following patch in cram_highlevel:

diff --git a/cram_physics_utils/src/assimp-grovel.lisp b/cram_physics_utils/src/assimp-grovel.lisp
index e1b6413..8c43062 100644
--- a/cram_physics_utils/src/assimp-grovel.lisp
+++ b/cram_physics_utils/src/assimp-grovel.lisp
@@ -28,11 +28,11 @@
 ;;; POSSIBILITY OF SUCH DAMAGE.
 ;;;

-(include "assimp/assimp.h")
-(include "assimp/aiMesh.h")
-(include "assimp/aiScene.h")
-(include "assimp/aiMaterial.h")
-(include "assimp/aiPostProcess.h")
+(include "assimp/types.h")
+(include "assimp/mesh.h")
+(include "assimp/scene.h")
+(include "assimp/material.h")
+(include "assimp/postprocess.h")

 (in-package :physics-utils)

Just copy-paste it to a file, e.g. ~/assimp3.patch. Then execute the following commands:

roscd cram_highlevel
patch -p1 < ~/assimp3.patch
edit flag offensive delete link more
0

answered 2012-11-15 02:00:18 -0500

ZiyangLI gravatar image

updated 2012-11-15 02:00:35 -0500

Thanks for reply. I have tried your solution but my system is ubuntu10.04 and I can only find following libraries:

libassimp2 libassimp3.0-r1264 libassimp3.0-r1264-dev

I have them all installed but still have that problem.

edit flag offensive delete link more

Comments

Please read the support page. Do not create answers for discussion or additional comments but edit your original post. That's what the edit functionality is for. Can you provide the contents of the *inferior-lisp* emacs buffer? It should contain more information

Lorenz gravatar imageLorenz ( 2012-11-15 02:23:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-15 01:46:03 -0500

Seen: 349 times

Last updated: Nov 21 '12