Ask Your Question
0

Can't start gazebo

asked 2012-11-10 14:10:07 -0600

amh gravatar image

updated 2012-11-12 19:18:51 -0600

I am just starting with ROS. On a new Ubuntu 12.04 installation, i issued apt-get ros-fuerte-* and installed everything (except openni-dev that needs SSE3 and i have only SSE2).

Now i can't start gazebo!!

roslaunch gazebo_worlds empty_world.launch 
... logging to /home/amh/.ros/log/348d8d28-2b9c-11e2-85c7-00166f6382d6/roslaunch-amh-Latitude-D610-17941.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://amh-Latitude-D610:57229/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    gazebo (gazebo/gazebo)
    gazebo_gui (gazebo/gui)

auto-starting new master
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[master]: started with pid [17957]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 348d8d28-2b9c-11e2-85c7-00166f6382d6
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[rosout-1]: started with pid [17970]
started core service [/rosout]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[gazebo-2]: started with pid [17984]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[gazebo_gui-3]: started with pid [17991]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345
Msg Waiting for master[ INFO] [1352596072.851921503]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://localhost:11345
[ INFO] [1352596074.145719550]: joint trajectory plugin missing <updateRate>, defaults to 0.0 (as fast as possible)
Illegal instruction (core dumped)
[gazebo-2] process has died [pid 17984, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=gazebo __log:=/home/amh/.ros/log/348d8d28-2b9c-11e2-85c7-00166f6382d6/gazebo-2.log].
log file: /home/amh/.ros/log/348d8d28-2b9c-11e2-85c7-00166f6382d6/gazebo-2*.log
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 17994 Illegal instruction     (core dumped) `rospack find gazebo`/gazebo/bin/gzclient -g `rospack find gazebo`/lib/libgazebo_ros_paths_plugin.so
[gazebo_gui-3] process has died [pid 17991, exit code 132, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/amh/.ros/log/348d8d28-2b9c-11e2-85c7-00166f6382d6/gazebo_gui-3.log].
log file: /home/amh/.ros/log/348d8d28-2b9c-11e2-85c7-00166f6382d6/gazebo_gui-3*.log

BTW, /opt/ros/fuerte/stacks/simulator_gazebo/CMakeLists.txt shows 1.6.16. I am confusing this with 1.0.2 (written in above log) and 1.2 on http://gazebosim.org !!

Please help me getting started with ROS.

Thanks

Update I am using Ubuntu 12.04 LTS. The output of lspci |grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03 ...
(more)
edit retag flag offensive close merge delete

Comments

1.6.16 is the version of the simulator_gazebo (ROS) package.. it uses Gazebo 1.0.2 which is a standalone piece of code.

SL Remy gravatar imageSL Remy ( 2012-11-11 06:41:52 -0600 )edit

Can you edit your question and include some information? What operating system are you using? (e.g. Ubuntu Precise, Debian Squeeze, etc.). What is the result of lspci |grep VGA (what graphics card are you using)?

SL Remy gravatar imageSL Remy ( 2012-11-11 07:02:37 -0600 )edit

Could you try roslaunch gazebo_worlds empty_world_no_x.launch

SL Remy gravatar imageSL Remy ( 2012-11-12 02:58:46 -0600 )edit

still the same error (Update 2)

amh gravatar imageamh ( 2012-11-12 06:54:26 -0600 )edit

@Amal Please check my Update 3

amh gravatar imageamh ( 2012-11-12 19:22:11 -0600 )edit

@amh roslaunch starts a roscore if there isn't already one running

SL Remy gravatar imageSL Remy ( 2012-11-13 02:09:16 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2012-11-13 02:16:32 -0600

SL Remy gravatar image

It seems that it truly may be the gazebo server that is segfaulting...

I'd suggest running roslaunch gazebo_worlds debug.launch and reporting the issue on Gazebo Trac

edit flag offensive delete link more
0

answered 2012-11-12 07:27:10 -0600

آمال gravatar image

try use

rosmake gazebo_worlds

before use

roslaunch gazebo_worlds empty_world_no_x.launch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-10 14:10:07 -0600

Seen: 2,897 times

Last updated: Nov 13 '12