Ask Your Question
0

camera1394: No cameras found

asked 2012-11-02 02:36:12 -0500

liborw gravatar image

Hi, I have camera connected through firewire:

$ lsfirewire
fw0: Linux Firewire Juju
fw1: Point Grey Research Flea2 FL2G-50S5C

However, when I try to run camera1394_node I get:

$ rosrun camera1394 camera1394_node 
[ERROR] [1351859527.447323402]: [camera] device open failed: [Camera1394::open]: No cameras found

I have tested the camera on another machine and it worked without problems. This machine does not have graphical interface so coriander is not an option here.

edit retag flag offensive close merge delete

Comments

Did camera1394_node work on the other machine?

joq gravatar image joq  ( 2012-11-02 05:57:26 -0500 )edit

Yes, it works.

liborw gravatar image liborw  ( 2012-11-04 19:20:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-06 04:35:20 -0500

joq gravatar image

So far, there is no evidence of a ROS driver problem. The Flea 2 is known to work with camera1394, and your camera works with it on another system.

You may be able to run coriander (slowly) on a system with a display by using a remote X connection.

If that does not work and presuming the driver and the camera do work, the next step is to check the stuff in the middle.

  • Is the 1394 cable working? Maybe try a different one.

  • Is the 1394 host adapter on your headless system good? Apparently it found the device, but there could still be troubles actually talking to it.

  • Is this kernel firewire driver identical to the one on the system that worked? (Probably OK, Juju is the latest firewire driver for Linux.)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-02 02:36:12 -0500

Seen: 478 times

Last updated: Nov 06 '12