Ask Your Question
0

[solved] gazebo_plugins in ROS fuerte: permission denied

asked 2012-11-01 02:07:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi guys,

I have a weird problem when I add as dependency gazebo_plugins in a package built with ROS fuerte. If a add this dependency in a manifest.xml like the following one

<package> <description brief="labrob_diffDrive3d_gzPlugins"> Contains plugins for Gazebo. </description>

<author>Neostek</author>
<license>BSD</license>
<review status="unreviewed" notes=""/>
<url>http://ros.org/wiki/diffDrive3d</url>
<depend package="roscpp"/>
<depend package="gazebo"/>
<depend package="gazebo_plugins"/>

<export>
    <gazebo plugin_path="${prefix}/lib" />
</export>

</package>

and I compile my package ros tells me the following

[rosmake-1] Starting >>> gazebo_plugins [ make ]
[ rosmake ] All 2 lines {------------------------------------------------------------------------------- mkdir: cannot create "build" directory : Permission denied -------------------------------------------------------------------------------} [ rosmake ] Output from build of package gazebo_plugins written to:

If I remove that dependency everything goes fine.

I need this dependency since this package is also suited for ROS electric that needs that, otherwise it cannot find folders like odometry and more.

Does anyone has the same problem? How can I solve it?

Thanks in advance for any responce,

Neostek

edit retag flag offensive close merge delete

Comments

It seems to be the problem of gazebo_plugins package.

Po-Jen Lai gravatar image Po-Jen Lai  ( 2012-11-07 03:45:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-07 20:39:50 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I solved this problem. I do not know why there is no NO_BUILD file in gazebo plugin packagem then ROS tries to compile that package that is in /opt where it has no permission. If you reset the file, then everything is fine.

edit flag offensive delete link more

Comments

1

Never change any files in /opt. That is really bad, not only because your changed files will be overwritten by the next update. Instead, always create an overlay. See http://ros.org/wiki/fuerte/Installation/Overlays

Lorenz gravatar image Lorenz  ( 2012-11-08 00:20:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-01 02:07:07 -0500

Seen: 211 times

Last updated: Nov 07 '12