ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

a problem after "rosrun openni_camera openni_node"

asked 2012-10-30 16:33:38 -0600

sven_007 gravatar image

After I run the command "rosrun openni_camera openni_node",it shows as below:

/opt/ros/electric/stacks/openni_kinect/openni_camera/bin/openni_node: relocation error: /opt/ros/electric/stacks/perception_pcl/pcl/lib/libpcl_visualization.so.1.1: symbol __cxa_pure_virtual, version libmysqlclient_16 not defined in file libmysqlclient.so.16 with link time reference

Is there anyone who can tell me why?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-10-30 16:54:36 -0600

Try this:

sudo apt-get install libmysqlclient16

If the command above didn't work, make sure to check that the update repositories are enabled by checking /etc/apt/sources.list, you may need this.

edit flag offensive delete link more

Comments

it worked. Thanks!

sven_007 gravatar image sven_007  ( 2012-10-30 16:59:53 -0600 )edit

Welcome :)

Po-Jen Lai gravatar image Po-Jen Lai  ( 2012-10-30 17:01:20 -0600 )edit

Question Tools

Stats

Asked: 2012-10-30 16:33:38 -0600

Seen: 307 times

Last updated: Oct 30 '12