ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

pcl17 error while loading shared libraries

asked 2012-10-29 09:29:22 -0600

mouser58907 gravatar image

I'm currently building pcl17 with BUILD_GPU and BUILD_CUDA enabled. When I run the compiled pcl_kinfu_largescale

rosrun pcl17 pcl_kinfu_largescale

I get the following error:

/home/craig/fuerte_workspace/sandbox/perception_pcl_unstable/pcl17/bin/pcl_kinfu_largeScale: error while loading shared libraries: cannot open shared object file: No such file or directory

However, the libraries do exist in the directory perception_pcl_unstable/pcl17/build/pcl_trunk/build/lib.

It appears the kinfu binary is being ran in the fuerte_workspace folder, but I'm not sure if that affects the included library. I've also tried running the binary directly from the build folder. I've successfully built the pcl trunk and can run the kinfu binary that way, but I need to incorporate ROS into it so it is not much help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-10-29 13:38:46 -0600

mouser58907 gravatar image

Apparently this is a known issue within the point cloud library,

edit flag offensive delete link more

Question Tools


Asked: 2012-10-29 09:29:22 -0600

Seen: 608 times

Last updated: Oct 29 '12