Ask Your Question
1

PCL Tutorial voxel_grid Permission Denied

asked 2012-10-22 05:36:29 -0500

Amanda gravatar image

Hello,

I am new to ROS, Ubuntu, and PCL. I have Ubuntu 11.10. I am attempting to complete the ROS PCL Tutorials at http://www.ros.org/wiki/pcl/Tutorials. I got stuck at step 4.1.

I was unable to get the ./voxel_grid command to work in the linked part of the tutorial at the PCL website at http://www.pointclouds.org/documentation/tutorials/voxel_grid.php. I receive the following errors:

albertchi@albertchi-e6510:~/my_pcl_tutorial$ ./voxel_grid
bash: ./voxel_grid: No such file or directory
albertchi@albertchi-e6510:~/my_pcl_tutorial$ ./voxel_grid.cpp
bash: ./voxel_grid.cpp: Permission denied

I tried: albertchi@albertchi-e6510:~$ chmod 777 my_pcl_tutorial, but this did not change the output.

I moved on to the next step in the tutorial (the second part of step 4.1), and tried:

albertchi@albertchi-e6510:~$ rosmake my_pcl_tutorial
[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['my_pcl_tutorial']                         
[ rosmake ] Logging to directory /home/albertchi/.ros/rosmake/rosmake_output-20121022-112526
[ rosmake ] Expanded args ['my_pcl_tutorial'] to:
[]                            
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['my_pcl_tutorial']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

Obviously, this was unsuccessful as well. Suggestions would be appreciated. I am hoping it is something simple because I am new.

Amanda

edit retag flag offensive close merge delete

Comments

What does executing ls -la ~/my_pcl_tutorial give?

jbohren gravatar image jbohren  ( 2012-10-22 05:44:24 -0500 )edit

total 5568

drwxrwxrwx 4 albertchi albertchi 4096 2012-10-22 10:56 .

drwxr-xr-x 36 albertchi albertchi 4096 2012-10-22 09:39 ..

-rw-rw-r-- 1 albertchi albertchi 1569 2012-10-19 16:33 CMakeLists.txt

-rw-rw-r-- 1 albertchi albertchi 1254 2012-10-08 15:06 CMakeLists.txt~

Amanda gravatar image Amanda  ( 2012-10-22 05:53:39 -0500 )edit

-rw-rw-r-- 1 albertchi albertchi 761 2012-10-08 15:06 example.cpp

drwxrwxr-x 3 albertchi albertchi 4096 2012-10-08 15:01 include

-rw-rw-r-- 1 albertchi albertchi 120 2012-10-08 15:01 mainpage.dox

-rw-rw-r-- 1 albertchi albertchi 41 2012-10-08 15:01 Makefile

Amanda gravatar image Amanda  ( 2012-10-22 06:14:29 -0500 )edit

-rw-rw-r-- 1 albertchi albertchi 367 2012-10-08 15:01 manifest.xml

drwxrwxr-x 2 albertchi albertchi 4096 2012-10-08 15:01 src

-rw-rw-r-- 1 albertchi albertchi 5649007 2012-10-19 16:51 table_scene_lms400.pcd

-rw-rw-r-- 1 albertchi albertchi 1559 2012-10-22 10:56 voxel_grid.cpp

Amanda gravatar image Amanda  ( 2012-10-22 06:15:00 -0500 )edit

-rw-rw-r-- 1 albertchi albertchi 1591 2012-10-22 10:56 voxel_grid.cpp~

Sorry this is so long and broken up. Is there a better way for me to post a response in the future?

Amanda gravatar image Amanda  ( 2012-10-22 06:15:48 -0500 )edit

Instead of creating a lot of comments, it's better to edit the question.

Lorenz gravatar image Lorenz  ( 2012-10-22 06:19:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-22 05:41:33 -0500

Lorenz gravatar image

You need to set up a ROS workspace before you can compile your own packages. Have a look at this page and this tutorial.

edit flag offensive delete link more

Comments

Thank you for the guidance. I attempted to do this using two methods:

I tried to add the my_pcl_tutorial file to the ROS_PACKAGE_PATH using:

albertchi@albertchi-e6510:~$ rosws set ~/my_pcl_tutorial

albertchi@albertchi-e6510:~$ source /home/albertchi/setup.sh

but it returned the same error.

Amanda gravatar image Amanda  ( 2012-10-22 06:05:41 -0500 )edit

Second Method: I copied the entire my_pcl_tutorial folder into the fuerte_workspace folder and did:

albertchi@albertchi-e6510:~$ rosws set ~/fuerte_workspace/my_pcl_tutorial

albertchi@albertchi-e6510:~$ source /home/albertchi/setup.sh

but it returned the same error.

Amanda gravatar image Amanda  ( 2012-10-22 06:08:10 -0500 )edit

You must source ~/fuerte_workspace/setup.bash, not /home/albertchi/setup.sh. The latter file should even not exist at all.

Lorenz gravatar image Lorenz  ( 2012-10-22 06:21:06 -0500 )edit

I originally ran source /home/albertchi/setup.sh because the output of rosws set ~/fuerte_workspace/my_pcl_tutorial told me to run that command specifically. Idk why. I ran

albertchi@albertchi-e6510:~$ source ~/fuerte_workspace/setup.bash

and I received the same error as before.

Amanda gravatar image Amanda  ( 2012-10-22 06:41:53 -0500 )edit

do you solve it?I have the same problem.I am using ubuntu12.04+groovy,and I also source ~/my_ws/devel/setup.bash can you help me?

baogege gravatar image baogege  ( 2015-08-08 08:15:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-22 05:36:29 -0500

Seen: 245 times

Last updated: Oct 22 '12