Ask Your Question
0

dynamic_reconfigure package error??

asked 2012-10-14 22:21:29 -0500

roskidos gravatar image

updated 2016-10-24 09:02:41 -0500

ngrennan gravatar image

I'm testing kinect reading using openni_launch following instructions link: openni_launch tutorial

and when I came to the dynamic_reconfigure gui part. My kinect cannot be read anymore. I doubt that it did something to the original driver parameters

I tried to restart my PC and run the tutorial again (without dynamic_reconfigure) then it worked. Then how can I register the points??

What is the problem here?

Edit 01:

I changed Topic to registered depth points (without using dynamic reconfigure) or close RVIZ. All led to the same pending and unable to load kinect again

it only works again when I restart the PC

Edit 02:

I tried with rostopic echo /rosout to see the stream of data. But type of /rosout is rosgraph_msgs/Log and cannot be seen clearly i.e. matrix of number. I don't know how to see the image data yet

edit retag flag offensive close merge delete

Comments

So once you enable depth-registration openni stops publishing, do I understand correctly? Did you confirm this by echoing the topics (rostopic echo /camera/...)? If so, what happens when you disable depth-registration again? Does it continue to publish points or just freeze?

yigit gravatar image yigit  ( 2012-10-15 00:21:25 -0500 )edit

actually, I've just tried other things e.g. change Topic to registered depth points (without using dynamic reconfigure) or close RVIZ. They all led to the same pending and unable to load kinect again. I'm trying to show data using rostopic ... like you said. But whenever I restart the PC, it works

roskidos gravatar image roskidos  ( 2012-10-15 04:59:58 -0500 )edit
1

/rosout is not the image. It is a collection of ROS log messages. You can view them with rxconsole

joq gravatar image joq  ( 2012-10-15 06:44:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-15 05:33:06 -0500

joq gravatar image

updated 2012-10-15 06:45:58 -0500

This may be a bug in the driver. If some combination of parameters doesn't work on the device, it may hang with the driver unable to recover cleanly. If so, you should open a Trac defect ticket.

Does restarting only the driver get things working again? (Please edit your question to provide more information about that.)

EDIT: hard to tell much from your description. Either your device is not working or the driver is not contacting it correctly.

edit flag offensive delete link more

Comments

thank you for answering my question!! I'm working on capturing the output data. perhaps I will post the asnwer here

roskidos gravatar image roskidos  ( 2012-10-15 17:07:39 -0500 )edit

@ROSbeginner we had a similar issue. joq's answer led me to the right way. Please see here http://answers.ros.org/question/46066/kinect-dynamic-reconfigure-does-not-work/?answer=46450#post-id-46450

yigit gravatar image yigit  ( 2012-11-01 05:27:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-14 22:21:29 -0500

Seen: 247 times

Last updated: Oct 15 '12