std::logic_error when rosrun nodelet_manager [closed]

asked 2012-10-04 21:40:27 -0600

MiseryInDevice gravatar image

updated 2014-01-28 17:13:50 -0600

ngrennan gravatar image

Hello guys,

I want to set a nodelet project out of my existing one, so I started the tutorial - Running a nodelet for nodelets. But when I run the line

rosrun nodelet nodelet manager __name:=nodelet_manager

I get the message

terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct null not valid
Aborted (core dumped)

and I have no clue what I can do to solve it.

Google search by searching "basic_string::_S_construct null not valid" gives a clear answer, but I do not init a string anywhere.

when i run the launch file refering to the tutorial- Porting nodes to nodelets I get:

roslaunch my_testpkg mynodelet.launch 
... logging to /home/me/.ros/log/0ab06050-0e2f-11e2-a13e-0024d7c57128/roslaunch-me-PC-23795.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://localhost:59118/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion

NODES
  /
    mynodelet (nodelet/nodelet)
    standalone_nodelet (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[standalone_nodelet-1]: started with pid [23815]
process[mynodelet-2]: started with pid [23826]
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct null not valid
[ INFO] [1349416579.221977540]: Loading nodelet /mynodelet of type my_testpkg/mynodelet to manager standalone_nodelet with the following remappings:
[ INFO] [1349416579.225376091]: waitForService: Service [/standalone_nodelet/load_nodelet] has not been advertised, waiting...
[standalone_nodelet-1] process has died [pid 23815, exit code -6, cmd /opt/ros/fuerte/stacks/nodelet_core/nodelet/bin/nodelet manager __name:=standalone_nodelet __log:=/home/me/.ros/log/0ab06050-0e2f-11e2-a13e-0024d7c57128/standalone_nodelet-1.log].
log file: /home/me/.ros/log/0ab06050-0e2f-11e2-a13e-0024d7c57128/standalone_nodelet-1*.log
[mynodelet-2] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-06-30 19:04:28.211459

Comments

I just saw that, when I open rxgraph, i can see the nodelet (mynodelet) connected to rosout!?!

MiseryInDevice gravatar imageMiseryInDevice ( 2012-10-05 01:54:41 -0600 )edit

Were you able to solver this?

Grega Pusnik gravatar imageGrega Pusnik ( 2013-04-27 02:37:23 -0600 )edit

Is this issue solved? I am still getting this error.

naveedhd gravatar imagenaveedhd ( 2016-02-25 20:11:08 -0600 )edit