Ask Your Question
1

roboearth detection and other issues

asked 2012-10-03 05:55:58 -0500

yigit gravatar image

Hello everyone,

I am a newbie roboearth user and have recently managed to integrate roboearth with ros, resolving some build and run-time errors.

  • I start training roboearth with a bottle. The first problem I encounter is that I couldn't see any points on the screen (i.e.re_object_recorder does not receive any point clouds) when I enable depth-registration. On the contrary, I can see the points when I disable depth-registration. Here are two screenshots:

Depth Registration Enabled Depth Registration Disabled

  • I continue training with disabling depth-registration even if it explicitly stated otherwise. After training finishes, I upload my model to roboearth, everything seems fine up to this point. Then, I try to detect the bottle as it shown in the ros tutorials. I start openni (again, I disable depth-registration for the same reason) and other nodes (re_kinect_object_detector etc...). I download my object, and roboearth just doesn't recognize the bottle.

There is this hint in the tutorial page, which I really take into account. I believe my model is dense enough (you can search my model through roboearth api, it is called bottle.screensaversolution).

So, what might have gone wrong?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-03 06:28:41 -0500

ddimarco gravatar image

Please note that what you are using there is basically a 2D-feature based recognition algorithm. The depth information from the Kinect is just used for filtering out implausibly detected object poses. So you will get best results with a well-textured object. A good first test is to use the video game package that usually comes with a Kinect.

With that said, I really wonder about the problem with the depth registration here. It really should not make a difference for receiving a point cloud. Can you check with RViz if there is a point cloud published when you have depth registration enabled?

If you did not see them already, maybe also take a look at these hints.

edit flag offensive delete link more

Comments

Ddimarco thanks for your help and sorry it took me so long to reply. The problem about depth registration was caused by a bug (I suppose) in the openni drivers in the ubuntu repos. I built the drivers from the source and depth-registration problem is solved now. Then roboearth started to recognize.

yigit gravatar image yigit  ( 2012-10-30 02:52:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-03 05:55:58 -0500

Seen: 279 times

Last updated: Oct 03 '12