Ask Your Question
0

rosjava for Fuerte on Ubuntu 12.04

asked 2012-10-03 02:15:51 -0500

safzam gravatar image

Hi all, Is someone already using rosjava on Fuerte? How can I install these packages like rosjava_bootstrap,.etc.

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-03 11:01:14 -0500

Jyo gravatar image

I am currently using rosjava and rosjava.android on a 12.04 install, the documentation can be found at

Rosjava Install Documentation

That should walk you through the install process for everything, as well as get you started.

edit flag offensive delete link more

Comments

Hey...thanks. I have yesterday tried it from link http://docs.rosjava.googlecode.com/hg/rosjava_core/html/installing.html but it gives "ERROR: Ambiguous workspace: ROS_WORKSPACE=/home/safdar/rosrescue, /home/safdar/my_workspace/.rosinstall". Did you alsoinstall rosjava on Fuerte on ubuntu 12.04???

safzam gravatar image safzam  ( 2012-10-04 00:32:20 -0500 )edit

Hi joy! I have solved Ambigugous problem. I seemed to me that all steps are gone correctly. Now when I rosmake a rosjava based package then I get error [AttributeError: 'module' object has no attribute 'rosenv'] , Do you know why do I get this error?

safzam gravatar image safzam  ( 2012-10-04 02:37:12 -0500 )edit

rosjava does not support rosmake. I suggest going back to the documentation and making sure you can build and run the pubsub tutorial.

damonkohler gravatar image damonkohler  ( 2012-10-10 05:39:27 -0500 )edit

I get ERROR:Unzipping /home/.gradle/wrapper/dists/gradle-1.0-milestone-9-bin/7ilkmgo2rn79vvfvd51rqf17ks/gradle-1.0-milestone-9-bin.zip to /home/.gradle/wrapper/dists/gradle-1.0-milestone-9-bin/7ilkmgo2rn79vvfvd51rqf17ks Exception in thread "main" java.util.zip.ZipException: error in opening zip file

safzam gravatar image safzam  ( 2012-10-21 23:57:22 -0500 )edit

I imagine you have a corrupt download. Delete the zip file and try again.

damonkohler gravatar image damonkohler  ( 2012-10-23 01:36:55 -0500 )edit

its fine now. But if I run ../gradlew installApp from rosjava_tutorial_pubsub it builds successfully but I dont see any bin directory. if I run ./build/rosjava_tutorial_pubsub/bin/rosjava_tutorial_pubsub org.ros.rosjava_tutorial_pubsub.Talker then it gives error Data not found. how can I run Talker?

safzam gravatar image safzam  ( 2012-10-23 02:24:36 -0500 )edit

Please post a new question with your issue. Also, be sure to follow the rosjava tutorials: http://docs.rosjava.googlecode.com/hg/rosjava_core/html/getting_started.html#executing-nodes

damonkohler gravatar image damonkohler  ( 2012-10-23 02:59:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-03 02:15:51 -0500

Seen: 959 times

Last updated: Oct 03 '12