rgbdslam error while installing for natty [closed]

asked 2012-10-02 02:01:47 -0600

Prasad gravatar image

updated 2014-01-28 17:13:48 -0600

ngrennan gravatar image

Hello,

I am getting an error while installing rgbdslam and dependencies.

Failed to find rosdep libgsl for package rgbdslam on OS:ubuntu version:natty

Failed to find rosdep libqt4-dev for package rgbdslam on OS:ubuntu version:natty

Failed to find rosdep libdevil-dev for package rgbdslam on OS:ubuntu version:natty

Failed to find rosdep libqt4-opengl-dev for package rgbdslam on OS:ubuntu version:natty

Failed to find rosdep libglew-dev for package rgbdslam on OS:ubuntu version:natty

[ rosmake ] rosdep install failed: Rosdep install failed

All the shown packages are already installed

Do i have to upgrade the system to Ubuntu 11.10?

Abhimoh

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Felix Endres
close date 2012-10-21 22:58:17

Comments

Are you using ros electric or fuerte?

Felix Endres gravatar image Felix Endres  ( 2012-10-02 02:21:47 -0600 )edit

I am using electric

Prasad gravatar image Prasad  ( 2012-10-04 19:40:19 -0600 )edit

try updating the svn. The switch to the dependency names of fuerte broke the dependencies of electric. I updated rosdep.yaml in the repository, to make it work with electric too. Besides, you should be able to compile and use rgbdslam despite the above error anyway.

Felix Endres gravatar image Felix Endres  ( 2012-10-05 09:19:05 -0600 )edit

Solved, Thanks Felix

Prasad gravatar image Prasad  ( 2012-10-06 19:58:30 -0600 )edit

i have the same problem and I'm using the revision 3541. would be great to get your help

dinamex gravatar image dinamex  ( 2012-11-08 14:13:31 -0600 )edit

On what ubuntu version?

Felix Endres gravatar image Felix Endres  ( 2012-11-08 20:24:40 -0600 )edit