Ask Your Question
0

Can not conect to remote roscore running on ros-fuerte-ros-comm

asked 2012-09-28 07:37:09 -0500

agonzamart gravatar image

updated 2012-09-28 07:42:22 -0500

I have a vaio in wich is running an ubuntu 10.11 with ros-fuerte-ros-comm installed. And im trying to use it as a server for the roscore.

Im trying to connect a virtual machine,on another physical computer with virtualbox with ubuntu 10.11 installed on it and ros-fuerte-ros-desktop-full. I run roscore in the vaio, and it seems to work perfectly, but when i run :

rosrun turtlesim turtlesim_node from my virtual machine

I get this error:

1348840863.367236742: [registerPublisher] failed to contact master at vaio:11311

I have checked the tutorials, im able to connect each machine by ping and ssh. Virtualmachine Bridged. I have my $ROS_MASTER_URI=http://vaio:11311 I check tcpdump in the vaio and i see messages posting from the virtual machine when i try to run the turtlesim_node.

I think that is a problem with something in the vaio because i tried to connect an ASUS PAD, with some ros nodes implemented on it, in software that i have, that was already able to connect to a rosmaster on another computer in my lab (This is already tested) but wasn't able to connect it to the vaio either.

I will really appreciate any help, I have been with this three days already, im used to working on linux but i have only been working with ros for one month.

Thank you for any help!

edit retag flag offensive close merge delete

Comments

Do you have a firewall running on your vaio? Is the host name set up properly in DNS or your hosts file?

ahendrix gravatar image ahendrix  ( 2012-09-28 10:28:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-29 03:49:01 -0500

agonzamart gravatar image

Well I was able finally to connect, the two computers. Im sorry because the answer was on the ROS/EnvironmentalVariables page explanation. It seems that you have to change ROS_HOSTNAME variable to = your machine hostname in each of the networked computers you are using. Instead of the default variable localhost, which keeps others computers from being able to connect remotely to the master.

Thanks for your help!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-28 07:37:09 -0500

Seen: 491 times

Last updated: Sep 29 '12