Error when navigating erratic robot in rviz [closed]

asked 2012-09-19 01:39:38 -0500

ChengXiang gravatar image

Hi all. I am currently trying to give a goal to erratic using rviz using the 2d Nav Goal function. The 2D Nav Goal work for goal that is set nearby the robot. However, the planner plan display (which subscribe to the topic move_base_node/NavfnROS/plan) will show an error status when i try to give erratic a further goal, and the robot will stop moving. The description of the error under planner plan states: Transform [sender=/move_base_node] For frame [ ]:Frame [ ] does not exist

Does anyone know what should I do with this? Could this be solved by increasing the transform_tolerance parameter that is in the costmap_commom_params.yaml?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-04-23 03:28:07.201707


In addition, let say that I want to make the erratic move faster. Can I just increase the velocity parameters of erratic in the base_local_planner_params.yaml file?

ChengXiang gravatar image ChengXiang  ( 2012-09-19 01:55:31 -0500 )edit

Hi. I tried the goal setting on Rviz for Turtlebot. The same error occur when I set the goal too far away from the robot. So am I right to say that this error is unavoidable, meaning goal set too far away will definitely fail? Is there a way out of it?

ChengXiang gravatar image ChengXiang  ( 2012-09-30 23:31:53 -0500 )edit