Ask Your Question
0

RVIZ unable to load libdefault_plugin.so

asked 2012-09-09 22:45:41 -0600

BUTT gravatar image

updated 2012-10-09 06:18:25 -0600

Hi,

After I tried running motion planning example for PR2 robot , there is a problem with my RVIZ that it is unable to load libdefault_plugin.so and thus when I click add , an empty panel appears and I am unable to add any display type .e.g camera.

Exact error at the terminal when I launch RVIZis as follows ; "

  • [ERROR] [1349764334.800506677]: wxWidgets Error [/opt/ros/electric/stacks/robot_model/colladadom/lib/libcollada15dom.so: undefined symbol: _ZN7pcrecpp2RE4InitEPKcPKNS_10RE_OptionsE] [/opt/ros/electric/stacks/visualization/rviz/lib/libdefault_plugin.so]

" I shall be thankful if any one could guide me to get out of this.

edit retag flag offensive close merge delete

Comments

What versions of ROS / OS are you using?

jbohren gravatar imagejbohren ( 2012-09-10 04:08:33 -0600 )edit

I am using ROS Electric and Ubuntu 11.10.

BUTT gravatar imageBUTT ( 2012-09-10 08:38:30 -0600 )edit

this didnt help.I was onto some other work but now again need rviz and stuck with the same error when I run rviz.Have tried reinstalling ros-electric-visulaization package and robot_model too.Any ideas to above error ;

BUTT gravatar imageBUTT ( 2012-10-08 20:38:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-13 04:31:40 -0600

Jakub gravatar image

Check if you have compiled version of colladadom.

roscd colladadom
ls lib/

if the lib/ directory is empty try to recompile the package

rosmake colladadom
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-09 22:45:41 -0600

Seen: 215 times

Last updated: Oct 09 '12