Ask Your Question
0

How to solve 'No such file or directory: u'/opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch'?

asked 2012-09-05 23:45:44 -0500

sam gravatar image

updated 2014-01-28 17:13:35 -0500

ngrennan gravatar image

I use ubuntu 12.04 with fuerte.

I followed rgbdslam.

When I run rgbdslam,it shows the error:

  sam@sam:/media/Data/code/ros/slam/rgbdslam$ roslaunch rgbdslam kinect+rgbdslam.launch 
  ... logging to /home/sam/.ros/log/07543c9e-f807-11e1-8779-20cf30a23845/roslaunch-sam-21581.log
  Checking log directory for disk usage. This may take awhile.
  Press Ctrl-C to interrupt
  Done checking log file disk usage. Usage is <1GB.

  while processing /opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch:
  Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u'/opt/ros/fuerte/stacks/openni_camera/launch/openni_node.launch'
  sam@sam:/media/Data/code/ros/slam/rgbdslam$

How to solve it?

Thank you~

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
4

answered 2012-09-06 00:30:59 -0500

yigit gravatar image

updated 2012-09-06 00:47:24 -0500

I get rgbdslam to work as follows

roslaunch openni_launch openni.launch
rosrun rgbdslam rgbdslam

The topics that are necessary for rgbdslam node are published by openni.launch file. Just don't use kinect+rgbdslam. This has been working for me

edit flag offensive delete link more
1

answered 2012-09-16 00:28:06 -0500

RossK gravatar image

updated 2012-09-16 00:30:08 -0500

The openni drivers have changed in fuerte, and the kinect+rgbdslam.launch launch file is looking for the electric openni_camera launch file. You can fix this by changing the kinect+rgbdslam.launch file as such:

change

<include file="$(find openni_camera)/launch/openni_node.launch"/>

to

<include file="$(find openni_launch)/launch/openni.launch"/>
edit flag offensive delete link more

Comments

1

Tip: Make sure you have installed openni_launch, as it is no longer included in the openni_camera package.

Flowers gravatar image Flowers  ( 2012-09-16 01:28:01 -0500 )edit

This really looks like the answer.. but why it is not working for me - I do not know.. had to go with @yygyt

kleinsplash gravatar image kleinsplash  ( 2013-06-11 01:18:58 -0500 )edit
0

answered 2012-09-06 00:05:07 -0500

dornhege gravatar image
  1. Does the file or directory exist? Is openni_camera installed?
  2. As you use fuerte, the launch file might just not be written for fuerte, thus you need to adapt it. (Basically start the kinect with its launch file).
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-05 23:45:44 -0500

Seen: 1,631 times

Last updated: Sep 16 '12