Ask Your Question
0

the problem when running the node rviz

asked 2012-09-03 22:14:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

when I run the node "rviz" in the comamnd line like this:rosrun rviz rviz It shows as below:

The program 'rviz' received an X Window System error. This probably reflects a bug in the program. The error was 'BadDrawable (invalid Pixmap or Window parameter)'. (Details: serial 21 error_code 9 request_code 55 minor_code 0) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)

Is there problems with the node "rviz" or something wrong with my PC?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-09-03 23:04:22 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

http://ros.org/wiki/rviz/Troubleshooting

Hi, it's all written in the site! I use, before to run rviz, "export OGRE_RTT_MODE=Copy" and rviz runs!

edit flag offensive delete link more

Comments

Thank you very much!

sven_007 gravatar image sven_007  ( 2012-10-30 16:39:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-03 22:14:10 -0500

Seen: 132 times

Last updated: Sep 03 '12