Ask Your Question
0

Problem with rostopic

asked 2012-09-03 03:01:34 -0500

Arjun PE gravatar image

updated 2014-01-28 17:13:32 -0500

ngrennan gravatar image

I've created my own message type, and have a C++ program generating messages. When I attempt to listen to the messages using rostopic echo in my PC, then I get perfect values.

Then I tried to enter into Husky A200 by ssh ing and then executing a subscriber program which subscibes to my topic.

ssh administrator@cpr-sal-01 Then typed password and entered into Husky

roscd face_subscriber (where i have my subscriber code)

rosrun face_subscriber face_subscriber (my face_subscriber code)

The problem is that my topic is not found in rostopic list of Husky. This subscriber code works perfectly in my pC. What should I do to make my topic get in the rostopic list of Husky ?

PS - I have electric running in my system and Husky has Feurte running in it. (

Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
5

answered 2012-09-03 03:39:59 -0500

dornhege gravatar image

Seems like your network isn't setup properly. Before you run you own code, you should try with rostopic echo to eliminate error sources.

Where is you core running? Can you see other topics from the remote machine? Is the ROS_MASTER_URI and possible ROS_IP/HOSTNAME set correctly? If that all works, your topics should also come up.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-03 03:01:34 -0500

Seen: 288 times

Last updated: Mar 03 '13