Ask Your Question
1

help with erratic_robot

asked 2012-08-27 03:48:26 -0500

Nachum gravatar image

updated 2012-11-03 14:18:16 -0500

Eric Perko gravatar image

Hi i am trying to install erratic_robot and i am getting errors- E: Unable to locate package ros-diamondback-erratic-robot or after i did sudo apt-get update i got this long error- Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-diamondback-erratic-robot : Depends: ros-diamondback-ros (= 1.4.10-s1314988837~natty) but it is not going to be installed Depends: ros-diamondback-ros-comm (= 1.4.8-s1314988916~natty) but it is not going to be installed Depends: ros-diamondback-robot-model (= 1.4.0-s1315008455~natty) but it is not going to be installed Depends: ros-diamondback-common (= 1.4.3-s1315005864~natty) but it is not going to be installed Depends: ros-diamondback-simulator-gazebo (= 1.2.8-s1315019072~natty) but it is not going to be installed Depends: ros-diamondback-navigation (= 1.4.2-s1315423226~natty) but it is not going to be installed Depends: ros-diamondback-laser-pipeline (= 1.2.0-s1315009845~natty) but it is not going to be installed Depends: ros-diamondback-motion-planning-common (= 0.3.6-s1315012421~natty) but it is not going to be installed Depends: ros-diamondback-slam-gmapping (= 1.2.3-s1315532575~natty) but it is not going to be installed Depends: ros-diamondback-geometry (= 1.4.2-s1315006035~natty) but it is not going to be installed Depends: ros-diamondback-common-msgs (= 1.4.0-s1315005773~natty) but it is not going to be installed Depends: ros-diamondback-pr2-simulator (= 1.4.3-s1315534131~natty) but it is not going to be installed Depends: ros-diamondback-point-cloud-perception (= 0.5.2-s1315018265~natty) but it is not going to be installed E: Unable to correct problems, you have held broken packages. does any one have an idea what should be done?

thanks.

edit retag flag offensive close merge delete

Comments

you have to install it like this: sudo apt-get install ros_fuerte_erratic_robot, and thats all!! good luck!

joseescobar60 gravatar image joseescobar60  ( 2012-11-04 22:47:27 -0500 )edit

Strange, when i tried your method, I get an error, E: Unable to locate package ros_fuerte_erratic_robot. Does anyone knows where I went wrong?

ChengXiang gravatar image ChengXiang  ( 2012-11-05 13:25:23 -0500 )edit

The proper command is: "sudo apt-get install ros-fuerte-erratic-robot", notice the dashes (-) instead of underscores(_).

arebgun gravatar image arebgun  ( 2012-11-05 13:29:21 -0500 )edit
1

Thanks arebgun! It works!

ChengXiang gravatar image ChengXiang  ( 2012-11-05 13:34:22 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-09-05 00:31:46 -0500

Eric Perko gravatar image

updated 2012-11-03 14:17:48 -0500

Diamondback is not supported on Ubuntu 12.04 . If you want to install erractic_robot on 12.04 under Fuerte, try for a package like ros-fuerte-erratic-robot. If that deb doesn't exist, you can try installing from source if that package, but the package may or may not be supported on 12.04 & ROS Fuerte.

UPDATE: erratic_robot is available for 12.04 and ROS Fuerte and is available in the package repositories.

edit flag offensive delete link more

Comments

1

erratic_robot stack is supported in Fuerte and is available in Ubuntu 12.04, there shouldn't be any problems installing it from package repository.

arebgun gravatar image arebgun  ( 2012-09-14 12:06:35 -0500 )edit

I can verify this. I just installed erratic_robot from Fuerte under Ubuntu 12.04 today, and everything seems to work as advertised.

Bill Smart gravatar image Bill Smart  ( 2012-11-02 22:18:23 -0500 )edit
0

answered 2012-10-31 02:26:06 -0500

joseescobar60 gravatar image

i have the same problem, do you know how to solve it???

edit flag offensive delete link more

Comments

2

Nachum's problem was that he tried to install not appropriate package. You should try ros-fuerte-erratic-robot/

Peter Listov gravatar image Peter Listov  ( 2012-11-01 21:05:20 -0500 )edit
0

answered 2012-09-05 00:02:33 -0500

Peter Listov gravatar image

What versions of Linux and ROS do you use?

edit flag offensive delete link more

Comments

ubnto 12.04 , ros fuerte

Nachum gravatar image Nachum  ( 2012-09-05 00:15:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-27 03:48:26 -0500

Seen: 542 times

Last updated: Nov 03 '12