Ask Your Question
2

Gazebo can't find rendering system

asked 2012-08-21 00:58:01 -0500

ChengXiang gravatar image

Hi everyone ! I have installed the linux OS Ubuntu 12.04 and gazebo-1.0.1 on my laptop. Although the installation of Ubuntu 12.04 is successful, I ran into some issues while running gazebo. I hope that you guys can give me some advices on how to resolve them.

I have already installed the debian package of gazebo 1.0.1 using the software centre and set the environment variables as described in the online instructions. However, when i tried to run " gzserver" in the terminal. it returned the following error

Msg Waiting for master Msg Connected to gazebo master @ http://localhost:11345 Error [RenderEngine.cc:356] Unable to load Ogre Plugin[/usr/lib/x86_64-linux-gnu/OGRE-1.7.4/Plugin_CgProgramManager.so]...Skipping

After that I added OGRE PPA, but it didn't help. I then downloaded and installed latest version of OGRE and run "gzserver" again, but it gave me another set of errors,

Exception [RenderEngine.cc:468] unable to find rendering system

Error [Rendering.cc:37] Failed to load the Rendering engine subsystem unable to find rendering system Exception [RenderEngine.cc:468] unable to find rendering system

Exception [Sensors.cc:39] Unable to load the rendering engine

terminate called after throwing an instance of 'gazebo::common::Exception' Aborted (core dumped)

Could anyone here help me with this issue? Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-08-21 18:39:17 -0500

Sanket_Kumar gravatar image

i think your gazebo is not completely integrated with ogre...you have to install gazebo with source pkg as in debian package it does not completely integrates with ogre...other things u can do is that to check whether u have setup environment variables correctly.

edit flag offensive delete link more

Comments

Thanks Kumar. I understand that you solved the problem by reinstalling using source pkg. May I know did you encounter problems while doing Cmake? I encountered build error ( e.g.missing: tinyxml) while doing Cmake. I followed the steps in the Readme text.

ChengXiang gravatar image ChengXiang  ( 2012-08-21 19:05:04 -0500 )edit

have u installed the requirements for gazebo???http://gazebosim.org/wiki/requirements

Sanket_Kumar gravatar image Sanket_Kumar  ( 2012-08-21 19:06:23 -0500 )edit

Ah! I think not. That should be it. Thanks a lot ! I will try installing again. Have a nice day!

ChengXiang gravatar image ChengXiang  ( 2012-08-21 19:16:08 -0500 )edit
0

answered 2012-08-21 09:00:45 -0500

Zara gravatar image

Have you looked at this page? http://answers.ros.org/question/12947/unable-to-run-gazebo-100-rc2/ which talks about same issue.

edit flag offensive delete link more

Comments

Hi Zara. Ya I have looked at that page already and try to reinstall gazebo using source pkg. but I run into problem while trying to Cmake it. Thus I hope that someone can give a more detailed explanation here, or perhaps an alternative method?

ChengXiang gravatar image ChengXiang  ( 2012-08-21 17:54:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-21 00:58:01 -0500

Seen: 924 times

Last updated: Aug 21 '12