RoS / Explore_lite ignores log4j.logger.ros.explore_lite=INFO

asked 2023-08-05 05:49:12 -0500

KevWal gravatar image

Hi All

A minor but annoying issue.

I have been playing with ROS1 for 8 weeks or so.

I have a robot built - 2 motors and a caster - differential drive, pi 4 (no arduinio etc), motor controller, wheel encoders, ld19 lidar, ICM20948 IMU.

I have Ubuntu 20.04 on the Pi and on a virtual machine on the laptop, ROS Noetic installed on both, a driver node and odom node written, ld19 and imu drivers working into ROS.

My (I say my, mostly used from various tutorials) code is all here: https://github.com/KevWal/ROS-Bot-Wor...

I am playing with explore_lite, but is seems to default to having various debuging turned on with lots of output like this:

[DEBUG] [1691188951.853357397]: received full new map, resizing to: 1024, 1024
[DEBUG] [1691188951.854879122]: full map update, 1048576 values
[DEBUG] [1691188951.860070762]: map updated, written 1048576 values
[DEBUG] [1691188952.099081635]: found 9 frontiers
[DEBUG] [1691188952.099213076]: frontier 0 cost: -176.948036
[DEBUG] [1691188952.099270260]: frontier 1 cost: -50.878135

I have been trying to learn about debug settings. I can see the settings in rosconsole:

pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole list explore
ros
ros.actionlib.ConnectionMonitor
ros.explore_lite
ros.explore_lite.actionlib
ros.roscpp
ros.roscpp.roscpp_internal
ros.roscpp.roscpp_internal.connections
ros.roscpp.superdebug

and can see them set:

pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole get explore ros.explore_lite.actionlib
info
pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole get explore ros.explore_lite
debug

and I can successfully change ros.explore_lite.actionlib through a "custom_rosconsole.conf" file referred to in the launch file:

custom_rosconsole.conf file:

# Noetic defaults
log4j.logger.ros=INFO
log4j.logger.ros.roscpp.superdebug=WARN

# Kev Custom settings
log4j.logger.ros.explore_lite=INFO
log4j.logger.ros.explore_lite.actionlib=WARN

.launch file contains:

<env name="ROSCONSOLE_CONFIG_FILE"
       value="$(find edukit_bot)/config/custom_rosconsole.conf"/>

but I can not for the life of me get it to change the ros.explore_lite setting:

pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole get explore ros.explore_lite.actionlib
warn
pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole get explore ros.explore_lite
debug

I can change it successfully through rqt_logger_level:

image description

but not thorugh my custom_rosconsole.conf file it seems?

pi@pi-ros-kev:~/edukit_bot_ws/src/edukit_bot/config$ rosconsole get explore ros.explore_lite
info

Thanks very much Kevin

edit retag flag offensive close merge delete