Arduino Nano IoT Unable to sync: Possible link problem or link software version mismatch

asked 2023-08-03 03:43:44 -0600

ElectricRay gravatar image

Hello All,

I keep having the message "Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino"

No maybe when someone reads this post and think wow there are quite some post and google hits on this issue. And yes I agree and have read a lot of them. Most of them relate to the incorrect baudrate. So far as I know this is not my case and I have tried in my code to lower the baudrate as test as well. Than I thought maybe it is because of my own code so I went one step back and used the HelloWorld example but still it is not working. I will try to explain what I am doing at the moment.

I run ROS Noetic on my virtual machine (VMware) Ubuntu 20.04.

I run VSC with PlatformIO on my Windows11 native machine.

Pyhton version on my Linux machine is: Python 3.8.10

So I program the Nano 33 IoT with (now in the latest case) with the HelloWorld example from the ROSserial library. A simple copy paste action. Than I disconnect the Nano from my native machine in order to connect it to the Virtual Machine and being able to see it. I have checked the port and it is ttyACM0, I did several checks with ls /dev/tty* , to be sure I know which port I need to adress.

Than I start ros with roscore and in another terminal I give the command rosrun rosserial_python _port:=/dev/ttyACM0 _baud:=57600

I keep having the following message(s) rosserial error

Note that I have changed the baudrate to lower values in the python script that came with the rosserial package. I do not have the Arduino IDE running on my Linux Virtual Machine but as far as I understood from the tutorials this is not needed, I don't see the point of that to do it. When my code would work I place the package on my Jetson Nano and will never use the Arduino Nano on that machine anymore.

Well I hope I have give enough information so that someone could help me fix this, probably I make somewhere a curcial mistake.

Thanks in advance

edit retag flag offensive close merge delete