vectornav driver doesn't post any INS messages

asked 2023-07-31 17:34:22 -0500

kozinovsky gravatar image

Hello!

I've already posted the same question on the GitHub page of the VectorNAV driver: vectornav_driver But no luck, noone get back to me, looks like the branch isn't in much support right now.

My system is Ubuntu 18.04, ROS1 Melodic (trying to get INS messages on x86 computer now, but final goal is Nvidia TX2, which is ARM computer if it matters)

First, I wanted to make my own node, using Python 3, because VectorNAV provides Python 3.4+ libraries and they are super easy to use for me. But, as I mentioned above, my system is using ROS1 and it has Python 2.7 as a default. I know, that it is possible to change default version for the ROS1 to Python 3x, but I have a lot of nodes, which were built based on Python 2.7 libraries.

I've asked VectorNAV support do they have Python 2 libraries, they answered negative and redirected me to the ROS1 VectorNAV driver which is already exists: dawonn_vectornav Which is based on C++ script. After that I've downloaded this driver, built it in my catkin space and tried to use.

The problem is that I can't see the messages with "roll" "pitch" and "yaw" angles information (in degrees, as i says in msg/Ins.msg file)

My device is VN100 according to this I've modified /launch/vectornav.launch file to: image description

After running the commands:

sudo chmod a+rw /dev/ttyUSB0

and

roscore

and after that

roslaunch vectornav vectornav.launch

Using rostopic list I can see the following topics:

~/catkin_ws$ rostopic list
/rosout
/rosout_agg
/vectornav/GPS
/vectornav/IMU
/vectornav/INS
/vectornav/Mag
/vectornav/Odom
/vectornav/Pres
/vectornav/Temp

image description

and most of them works and shows me the messages: IMU for example: image description

or temperature:

image description

But the only one I need, with pitch, roll and yaw information, as I understand, should be in /vectornav/INS topic

and when I run the command:

rostopic echo /vectornav/INS

it just give me nothing:

image description

I've found one problem, that Ins.msg which you can see in the package:

image description

weren't build at first, but now I've modified the package.xml and CMakeLists.txt and using command

rosmsg list show

I can see vectornav messages: image description

which should contain yaw, roll and pitch information: image description

But, again, as I mention above, command

rostopic echo /vectornav/Ins

gives me nothing:

image description

Looks like the only things which works (publishing working) are the standard std messages, such as /sensor_msg/temperature or /std_msg/IMU

image description

And logically to think that the problem with building the custom messages.. But I see now that they were succesfully built as I showed above.

Anyone has any advise? Or maybe someone faced with the similar problem using VectorNAV VN100?

Best, Andrey

edit retag flag offensive close merge delete