Trying to install ros: impossible to install rospy [closed]

asked 2023-06-03 05:09:44 -0500

Hedwin gravatar image

updated 2023-06-04 07:05:25 -0500

Mike Scheutzow gravatar image

Hi. I'm trying to install ros.

First of all, I'm on ubuntu 20.04

I tried to install ros melodic, kinetic and finally noetic but the latest was the only one found by my apt-get command. I then installed noetic using aptitude because apt-get had an unsolvable issue of unmeet dependencies.

No I'm trying to run catkin make on git cloned rosjects, bu i encounter the error bellow:

CMake Error at /opt/ros/noetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
Could not find a package configuration file provided by "rospy" with any of
the following names:


Add the installation prefix of "rospy" to CMAKE_PREFIX_PATH or set
"rospy_DIR" to a directory containing one of the above files.  If "rospy"
provides a separate development package or SDK, be sure it has been
Call Stack (most recent call first):
openai_ros/openai_ros/CMakeLists.txt:10 (find_package)

I solved it by doing sudo apt-get install ros-noetic-rospy but then I got:

Command 'rosdep' not found, but can be installed with:

sudo apt install python3-rosdep2

So I did the said command "sudo apt install python3-rosdep2", but now I got the first error again (the one about rospy) so I iterated a bit more in this poop loop, by trying to install these packages in another way (I tried sudo apt-get -y install python3-rospy) but I still got this error. How can I solve it ?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Hedwin
close date 2023-06-05 03:27:57.102203


You should NOT have packages python3-rospy or python3-rosdep2 installed. The proper solution is to resolve the apt "unmet dependencies" issue. Edit your description and copy/paste this error.

Also provide a link to the instructions you followed to install noetic.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2023-06-04 06:56:25 -0500 )edit

Another thought: to use the binary apt repo, you can NOT have an alternate version of python3 installed in /usr/local/bin/. noetic depends on the python version 3.8.10 installed from apt.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2023-06-04 07:04:52 -0500 )edit