Environment set-up problems with bash (ros2_iron)

asked 2023-05-25 07:18:38 -0500

jono gravatar image

Hello! I am very new to this, and this seems like a extremely trivial problem, but I have no idea how to fix it. I am following the steps to build ros2_iron from source on Ubuntu, everything worked great until the final step, where I have to set up the environment. The tutorial gives this command:

. ~/ros2_iron/install/local_setup.bash

I checked, the file is there, everything looks good. But, when i run that command instead of taking me to that directory to get the local_setup.bash file, it takes me here:

"/home/parallels/ros2_iron/install/rosbag2_transport/share/rosbag2_transport/local_setup.bash" so its looking for it in in the wrong place. I am new to bash and ros in general, so I really don’t know why when I explicitly type in the path where it must find the file, it looks for the file a couple of folders deeper. I have tried removing the contents from my .bashrc and .profile files, as I thought maybe there was some path variable that it was following, but that did not help. I am at a loss. Again i know this is likely a very trivial error, but I have no clue how to solve it, so any input would be greatly appreciated!! :)

Also I am running Ubuntu 22.04 ARM64 on a Mac through Parallels.

edit retag flag offensive close merge delete